Roon Stuck Adding Music to Library [Resolved]

It’s on 343 now with “only” about 106,000 more to go, LOL. Seems to be over taxing my “i7” Sonic Transporter leaving me with drop outs, hardware warning messages, etc. Have rebooted ST with only temporary help. Adding Music to Library always returns. Background & On-Demand Audio Analysis Speed are both off.

Would appreciate a response from Roon Support. Thanks.

Hi @Peter_Zwiefelhofer ---- Thank you for the report and my apologies for the inconvenience here. To help me better understand what may be causing this issue, may I kindly ask you to please provide the following information:

  1. A brief but accurate description of your setup as seen here. The more detailed you can be, the better :sunglasses:

  2. Please describe your network configuration/topology as well as providing insight into any networking hardware you may be implementing in your setup. I want to get an understanding of how your devices are communicating and what tools are being used to make those connections.

  3. How long have you noticed this behavior for? If this is a recent observation you have made and things were functioning as they should previously, can you think of any changes that have been made to your setup recently?


Try turning on background analysis and setting it to fast.

This worked in a similar situation for me when it seemed stuck, I saw it count down in real time after I changed the setting.

It shout finish once the 300 odd tracks are done.


Here’s my setup.

Running Roon 1.2 build 165 64 bit on ipad air 2 & “i7” Sonic Transporter. The ST is running Version 2.3.

AT&T 5268AC FXN modem to
Blue Jeans cat 6 to
Cisco 200-08 gigabit switch to
BJ cat 6 to
“i7” Sonic Transporter to
BJ cat 6 to
TP-Link MC100CM to
Tripp Lite Duplex Multimode 62.5/125 fiber (SC/SC) to
TP-Link MC100CM to
BJ cat 6 to
Micro rendu to
AudioQuest Cinnamon USB cable to
Schiit Gungnir multibit dac.

Music is on a 8tb WD My Book external hard drive connected to ST via USB cable.


This generally means that Roon is having trouble connecting to our servers, meaning something to do with your network.

Eric can work with you and gather more information to help identify the issue, but generally speaking you’ll want to simplify the network as much as possible to confirm everything works as expected. Then you can add in additional complexity to see where things are going awry.

Feel free to experiment in that direction, and @Eric will be in touch to make sure we get this worked out for you.

In addition, Roon has stopped identifying any new albums I add. Clearly Pink Floyd’s “The Wall” is in the database, but Roon doesn’t identify it or any other albums I’ve added recently. Would this further suggest that Roon is having trouble connecting to your servers?

In terms of simplifying my network, the only thing that occurs to me is to connect the ST directly to the AT&T modem, bypassing the Cisco switch. However, it was previously suggested that in order to resolve dropouts I should connect everything to a good switch to eliminate a possible bottleneck in the modem.

Also, when I try to check my account info in Roon, I get an error.

Looking forward to hearing from @Eric.

Thank you.

PS: Thanks for the suggestion, SJB. I gave it a try, but no help.

Yeah, all of this points to networking problems preventing Roon from communicating with our servers.

Can you give us a little more information about how things are set up? Is the Cisco switch unmanaged? Are jumbo frames enabled anywhere? Do you know how the Sonic Transporter get its IP address?

The switch is not managed. I’m unfamiliar with jumbo frames. Here’s a screen shot of the ST connection from my router.


Hi @Peter_Zwiefelhofer ----- Thank you for the follow up and providing the above screenshot. Both are appreciated!

A quick google search of “What are jumbo frames” had the following information to offer…

" A jumbo frame is an Ethernet frame with a payload greater than the standard maximum transmission unit (MTU) of 1,500 bytes. Jumbo frames are used on local area networks that support at least 1 Gbps and can be as large as 9,000 bytes."

Uses and limitations (the second paragraph sums up the concern here)…

" Enabling jumbo frames can improve network performance by making data transmissions more efficient. The CPUs on switches and routers can only process one frame at a time. By putting a larger payload into each frame, the CPUs have fewer frames to process. In return, this can reduce the amount of heat the network devices generate."

“These gains are only realized, however, if each link in the network path – including servers and endpoints – is configured to enable jumbo frames at the same MTU. Otherwise, performance may actually decrease as incompatible devices drop frames or fragment them, the latter of which can task the CPU with higher processing requirements. Enabling jumbo frames may also increase packet loss rates.”

With the above in mind, the devices you will want to check for jumbo frames are:

  • AT&T 5268AC FXN modem
  • Cisco 200-08 gigabit switch
  • TP-Link MC100CM


The AT&T 5268AC FXN modem & TP-Link MC100CM do not support jumbo frames.

Cisco calls the 200-08 “smart” & it does have a browser based interface. Does this mean its managed? It does appear to support jumbo frames. If this switch is a problem, what switch would you suggest as a replacement?


I swapped out the Cisco switch for at Zyxel GS-108B v2 I had lying around. This change seems to have resolved my issues. Adding music to library message is gone, Roon is identifying albums, I can access my account info and lost connection Message has dramatically declined.

Thanks for pointing me in the right direction.

Hi @Peter_Zwiefelhofer ----- Thank you for the follow up and sharing this feedback with me. Glad to hear that swapping the Cisco switch out helped here. Happy listening!