Roon stuck at 0:00 when playing to Apple TV

Core Machine (Operating system/System info/Roon build number)

Windows 10 PC - Roon version 1.7 build 528

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

PC and Apple TV both wired to a switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Airplay from Roon Core (PC) to AppleTV 4

Description Of Issue

Just getting Roon set up on my PC, plays fine on all devices connected to it (local, bluesound, etc) but will not play through my AppleTV. The AppleTV shows up in set up, the AirPlay authentication comes up on the screen, but when I actually try to play from my Roon core, it shows that it’s playing but is stuck at 0:00. I’ve tried Tidal, Qobuz, and local music, but nothing seems to actually work. Apple TV and Roon seems to be fully up to date. Is there something that I’m doing wrong or is there something wrong with one of my devices maybe? Any help on this would be greatly appreciated. Thanks in advance!

EDIT Forgot to mention, I’ve reset the Apple TV, the computer, the entire network, as well as performed a factory reset on the Apple TV. Nothing seems to help.

I assume the Apple TV is on version 13.4. When you go to Airplay settings on the Apple TV, what setting do you have for Allow Access?

I have Anyone on the Same Network.

Also, on the same screen, do you have Require Password set to On? If you do a 6 digit password is given below.

If I have Apple TV password set to No, when I try and Enable it in Roon, I get a 4 digit password. I can get Roon to accept it and Enable, but I can’t get music to play.

Let us know what Airplay settings you are using.

Cheers, Greg

Hey Greg, thanks for the reply.

I do have Apple TV version is 13.4. I have enabled access to everyone. I’ve tried both options as far as require password goes. It is currently set to on because I had seen a couple of people recommend this on the forum.

Hopefully this helps. I’m excited to use Roon and hope that I can get it set up properly to play on the Apple TV. Worst comes to worst, I can buy a bluesound node, but I’d rather avoid that if possible.

Thanks again.

We’ll have to wait for Support to help out.

In the meantime, what happens if you unplug the Apple TV from the switch and run it via wifi?

Cheers, Greg

Unplugged it from the hardline connection and connected it to Wifi instead. Same issue. If this helps at all, if I push play on Roon, it will look like it begins to play (play icon switches to pause icon) but will quickly return to the play icon within about a second. I hit play again and it shows the pause icon indefinitely, but does track time stays at 0:00. From what I can tell, this only happens on initial connection to the Apple TV. If I play something else on the Apple TV then switch back to Roon, the issue can be replicated. Not sure what that means, but hope it helps.


EDIT: Just verified, if I’m play something through airplay to the Apple TV, trying to start something on Roon interrupts what’s currently playing. It seems like a connection is being made to the Apple TV, but breaks before it can play anything and maybe gets stuck in some sort of limbo maybe?

Interesting. That’s a similar sequence of events I get when I have Password set to Off (sorry I wrote No above) and Apple TV gives me the 4 digit password on the tv screen. I hit play, it looks like it’s going to start to play, then goes back to the play icon. If I click it again, nothing happens for me, just the play icon.

When set to On, I get the 6 digit password in Apple TV settings, not on the screen. It works for me with this setting.

Strange. I’m not sure what to suggest from here. @support will be along to help you out.

Be sure to let us know the model of the switch. Also, if you’re running and firewall or antivirus software.

Cheers, Greg

Hi @Robert_Hungate,

Welcome to the forum. I requested that the hardware team attempt to reproduce your findings in the lab in case this is a firmware issue and they haven’t been able to do so, so this behavior might be something environmental on your end.

I would like to ask the technical team to review your Apple TV logs to see if we can find out more information regarding this issue. Before I go ahead and enable diagnostics mode for your account, can I please ask that you reproduce this issue and note the exact local time + date + track of the issue’s occurrence?

Thank you!

Hi @noris!

Time is 7:18 PM Eastern Time Zone. Date is April 16th, 2020. Tried to play track “Goodbye Yellow Brick Road” from Qobuz (I’ve tried Tidal and local tracks as well.) Issue persists.

As a side note, my roommate has an Apple TV as well. I swapped out his with mine to see if it was the Apple TV itself being defective. No change, issue persists.

Please let me know if you need any other information for me, but in the mean time I’m excited about finding a fix for this. I sell AV products and would like to get Roon up and running so that I can try it out at home and explain the benefits to clients (and hopefully make it easier to sell for me.) Thanks again for all your help!

Hi @Robert_Hungate!

Thank you for letting me know that timestamp, I have gone ahead and activated diagnostics mode for your Core and what this action does is automatically upload a log-set to our servers for analysis, I can confirm that the log set has been recieved.

I have requested the technical team to review the logs, but in the meantime I’d like to look over a few other potential reasons why this behavior could be occurring.

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

What kind of switch and router are you using? Could you please list the model/manufacturer?

If the switch is a managed one, you should be aware that we have often seen the need to enable specific settings to make a managed switch work properly with Roon, as mentioned in our Networking Best Practices.

If possible, I would try connecting both the Core and the Apple TV directly to the router or have them try to communicate over WiFi as a test to disprove the theory regarding the switch as being the issue.

Do let me know if either of the above suggestions help!

Hey @noris!

It seems that adding the firewall exceptions into Windows worked! It is now playing with no issue. Thanks so much for the help!

1 Like

That’s fantastic news @Robert_Hungate! I’m going to go ahead and mark this thread as [Solved] but if you have any further questions or issues, please feel free to reach out to us again. Take care and stay safe out there!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.