Roon stuck at starting screen [Solved - Tidal Login Corrupt]

Core Machine

iMac 2011 running High Sierra.

Network Details
ASUS Router connected via Ethernet

Audio Devices


Library Size

<2000 tracks

Description of Issue
Roon was working just last week. Now it’s stuck at the starting screen, with the animated logo. I already tried to reinstall, but it remais not starting.

This is the second time I seek Roon support for help. The first time the topic was closed without reply. Now I expect at least a reply, or I’ll just cancel my subscription, as it seems you have too many subscribers to care about just one. Right now I am not being able to use it at all.

I’m very sorry @Jorge_Alberto_Araujo that your post last time didn’t get resolved. It looks like it closed automatically after no activity, which was clearly our failure. We’re working on getting better systems (and more staff) in place to handle community inquiries.

A quick first check is to turn off your firewall/antivirus protection and see if Roon can initialize. If it does, you’ll want to add and to your exceptions list. This can sometimes be triggered by even small OS updates.

If you haven’t already done so, try rebooting your router

I see you’ve reinstalled Roon - try reinstalling the macOS as well.

Are you using Tidal or Qobuz? There might be a problem in the login files that’s interfering. I’ll send instructions for deleting that if nothing else has worked.

Let me know if anything changes with these steps and we’ll check further.

Kirsten, thank you for the quick reply. I tried all the steps you mentioned, except reinstalling my OS, which I didn’t even consider. Can you send instructions about the Tidal login files?

Hi @Jorge_Alberto_Araujo

Be SURE that Roon is not running when you do these steps:

  1. Open your File Explorer and go to %localappdata%\Roon\Database\Registry\Core
  2. In that folder, locate the tidal_account file and delete it.

After that, you can start Roon again and set up the connection to Tidal from scratch.

Let me know how that works.

While its probably nothing to do with the issue being experiences… thats a 10year old Mac and is officially under spec for roon’s min requirements - so you are likely not getting the ideal roon experience for performance that you could with more recent hardware

It worked, thanks.

You’re right, it’s nothing to do with the problem. It’s running perfectly now as it were before the problem.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.