Roon stuck checking for update of Innuos Statement

Core Machine (Operating system/System info/Roon build number)

Innuos Statement

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Statement is connected to network via Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Statement connected to Linn Klimax DSM via Ethernet

Description Of Issue

I have been controlling Roon with an iPad, which is telling me my Core (Innuos Statement) needs an update. It got stuck on ‘checking for an update…’ I rebooted the Statement and the screen in Roon said ‘You have the latest version installed’ and gave me a green tick. But it just stays stuck on that screen. I have tried rebooting the Statement again, via the Innuous web interface and good old turning it off at the wall.

What’s strange is that when I control Roon from my phone it works fine. Any ideas??

have you updated the ipad app to 1.7 too?

Nope, but now I have and it’s solved it. Muchas gracias!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.