Roon stuck in Indexing loop

Hi, I noticed today that Roon seems to be stuck in an indexing loop. Or perhaps it is stuck on certain files that cannot be indexed, which I can’t identify. This hasn’t happened in a long time, and it appears to coincide with the latest core update.

I run the latest version of Roon on a Late 2012 Mac mini, in an AudioQuest Forest cabled network. My music is stored on a Synology DS412+ NAS, also running on the latest software.

The only other thing that has changed is that I’m reviewing an iFi Pro iDSD at the moment, which is totally galvanically separated on all digital inputs, but I can’t see how that affects indexing.

Update: there seems to be some (very slow) progress after all. Below are three screenshots that were made at approximately 8 hour intervals, that show different numbers for imported tracks and scanned files. If I had to make a guess, it looks like Roon is currently sweating on the indexing of some incredibly large ‘ghost’ files, but I wouldn’t know how to identify and get rid of them…

Update 2: just a few minutes ago, before my very eyes, Roon started a new index after being ’stuck’ for some time.

I tried to stop it by restarting the Mac mini that Roon is running on, but to no avail.

I’m sorry for this, but I’m completely lost for a solution, so all that is left is using the @support tag…

Hi @Max_Delissen ---- Thank you for the report and sharing these observations with us. The feedback is appreciated and sorry to hear of the troubles.

Since noticing this behavior have you at any point tried mounting the NAS in Roon via the NAS’s IP address as opposed to using the work group address (i.e \DISKSTATION\music)? Furthermore, just to confirm the mentioned MacMini core has an SSD installed, correct? I seem to recall that model not coming with an SSD pre-installed but having the option to add one.


Good news? The problem seems to have solved itself! Yay!

First I tried to mount my Synology NAS using it’s IP address (\\123.456.789.01\music) instead of \\DISKSTATION\music, but that left the scanning indicator spinning.

Then I remembered that I had changed something else. A minor detail, I thought, but like the great Sherlock Holmes said: “when you have eliminated the impossible, whatever remains, however improbable, must be the truth.”

I had set the scanning interval to 8 hours instead of the default 4 hours. After I changed that back from 8 to 4, a new scan started that (finally) STOPPED WHEN FINISHED :wink:

Nope, celebrated too soon, still stuck…

Hi Eric,

This reply overrules the ones above.

Regrettably, I have to report that mounting the NAS by it’s IP address apparently didn’t do the trick after all. I could start a new index, and after that was done the information window displayed a summary, but only very briefly, and the blue indicator is still spinning in the top right corner. The information window tells me ‘Complete’ at the top, but below the storage path it still says ‘Scanning now…’

This means that we’ll have to dig deeper, doesn’t it?

Fortunately, I can still use Roon to play music, but this malfunction is starting to get quite disturbing and I’m not really sure if it affects sound quality.

What it does affect it listening to music though Roon in my home-office, where a Bluesound Node1 serves as playback device. Listening to internet radio goes smooth, listening to music from my NAS is distorted and after a short stuttering of dropouts, the entire signal goes ‘seeya!’.

I have removed the rotten folder completely now, and added it again as a ‘new folder’ using smb://DISKSTATION/music (which was automatically translated by Roon to \\DISKSTATION\music). It is scanning and importing ‘from scratch’ now, which may take a while. Especially the analysing of almost 100.000 files takes a while.

Perhaps we (or rather you) should have a look at my logfiles and NAS setup if this fails as well.

Hi @Max_Delissen ---- Thank you for the follow ups and the continued feedback. Having this additional insight is greatly appreciated!

Continuing forward, checking your logs is certainly a good ideas as they could contain traces that give us a clue as to why you are experiencing this behavior. However, before we go about gathering logs from your core there are two pieces of information I am currently seeking regarding your setup:

  1. From my previous:

    “Furthermore, just to confirm the mentioned MacMini core has an SSD installed, correct? I seem to recall that model not coming with an SSD pre-installed but having the option to add one.”

  2. Please describe how your core and the NAS are communicating on your network. Additionally, please be sure to provide detailed insight into any network hardware you are using to make these connection possible (i…e router, switches, etc).


Hi Eric,

In answer to your questions:

  1. There is no SSD in my Mac mini yet. I have bought one (Samsung EVO 860) and it’s ready to be installed by my handyman, but I haven’t made the appointment yet. So No SSD

  2. I’m not sure what you mean buy the first part of the question, but I use a wired connection, no WiFi.

My NAS (Synology 412+ with 6TB of storage) sits in the small cabinet in the hallway where the fuseboxes are, and where my internet/television/telephone modem is. The NAS is wired to the router (FRITZ!Box 7490) with AudioQuest Forest CAT700 cable. From that router, there is a single length of AudioQuest Forest CAT700 running to a D-Link DGS-108 switch behind my main stereo system where my Mac mini lives. The Mm is connected to that switch, also using an AudioQuest Forest CAT700.

I add music to my NAS from a MacBook Pro in my upstairs home office. The MBP is connected to the same router, using another D-Link DGS-108 switch and also a single length of AudioQuest Forest CAT700. No changes to any of the hardware were made lately, except for the addition of an iFi Pro iDSD DAC that I’m testing for a review. The Pro iDSD is also wired to the switch (with a bog-standard CAT6 cable), because it has a UPnP streaming module built in. I am not a great fan of UPnP (euphemistically speaking), but for review purposes I have downloaded the MUZO player app to use as a UPnP remote. The app really s*cks, but it is recommended by iFi, so waddaya gonna do?

Also connected to the switch in the main system are a 3rd gen AppleTV, an Arcadyan set top box + DVR, a Bluesound Node2 and an LG OLED Smart TV.

The new index I started after discarding the main Folder and setting a new one is at 40% at the moment. I expect it to be ready later this evening (it’s half past 5 PM right now) but the Background Audio Analysis may take a bit longer, since I’m running that on only 2 cores of the Mm’s CPU.

If you need any more technical details, please let me know :wink:

I notice you are past 100k tracks. Just asking the obvious really. Your core is 64bit? I used to get something similar with 32bit on hat 100k boundary.

Hi Tony, yes I thought of that too, thank you for noticing!

I checked a while ago when I was nearing 100k+ files. Fortunately, my Mac mini has a Core i5 processor, so it’s 64 bit.

I really do have to install an SSD and 16GB of RAM

After discarding the mount of the Music Folder and remounting that same Folder, the fresh index seems to work well and it appears to be stable. No more endless ‘busywheel-turning’ in the top right corner.

The only ‘setback’ is that 11 older abums have been moved to the front of the library in the ‘Sorted by Date Added’ album view, but that is a small price to pay. And somehow it has a way of sorting itself out. One day after re-indexing, they will simply be back at their original chronological places.

Hi @Max_Delissen ---- Thank you for the follow up and providing the requested feedback. Very appreciated!

I am pleased to hear that remounting the music folder has yielded a positive outcome and glad things are behaving as expected. I have went ahead an enabled diagnostics on your account as this action will automatically generate/upload a diagnostics reports containing a set of your Roon logs directly to our servers the next time Roon is active on your core machine. I will be sure to touch base again once the report has arrived so you know that we have it.

While I understand that you have purchased an SSD for the MAcMini, by chance during your troubleshooting of this behavior have you at any point tried testing with a core running on a device that has an SSD already in it?


Hmm, strange things are afoot here. The solution I thought I had found lasted until the next scheduled re-index. Since I performed the remount, I have added one new album to my NAS to see how that would work out, and now the infinite index-loop seems to be back again. So I’m glad you are harvesting some logs, perhaps they will show what the #§^@ is going on.

But first, to answer your question about the SSD: no, unfortunately I have not used a core running on an SSD during the troubleshooting. The only MacOS device that has an SSD in it is my Mid-2010 MacBook Pro, but that only has RoonBridge on it.

I have noticed some other strange things, and because of that a new suspicion is growing in my mind. But I’d prefer to discuss that in private, because my suspicion should not lead to assumptions or premature conclusions by those who are reading along. Can we open a PM session for that please?

Hi @Max_Delissen ---- Thanks for touching base with me! Confirming that I have seen your PM and have responded.

I checked our servers this morning and it looks like the mentioned diagnostics report has made it to us :thinking: I have since re-enabled this feature on your account and will continue to monitor. In the mean time I would be very curious to see how the NAS performs when your Roon core is being hosted on the mentioned MacBook Pro. Obviously this configuration would only be temporary, but I want to be certain that there is not some kind of core performance issue occurring which could be causing stuff with the NAS to time out.


No harm in trying I guess. Should I temporarily uninstall Roon Core from my Mac mini before I install it on my MBP? Or should I just shut off the Mm and use the MBP instead?

And would I need to hook the MBP up to the same DAC as my Mm is on now? Or can I use my Peachtree Decco in my office for this part of the test? I do need my MBP the next few days and next week to finish some work before my vacation starts.

Indexing for the ‘Test Core’ on my MacBook Pro (with SSD and 8GB RAM). Tried some tracks that were indexed first and they played perfectly. Now we wait and see what happens when the index is ready…

Hi @Max_Delissen ---- Thanks for the follow ups and my apologies for the delay on my end.

I appreciate you giving the proposed test a shot and look forward to hearing what observations are made during this troubleshooting exercise. I can see your ticket is still in our tech team’s queue for evaluation, as soon as they provide me an update I will be sure to share their thoughts/findings with you asap.

Again, many thanks!

Bad news I’m afraid. The ‘new’ Core (Roon Server) install on my SSD’d MacBook Pro started off promising, but after adding new music and lettiing the next automated index commence, it appears to be stuck again.

This time it happens while the core is connected to a different DAC, so it looks like we can exclude the USB connection to any DAC as the reason for the NAS time-out.

I will keep monitoring events, try new solutions if I can think of any and report what happens, right here in this thread.

Thanks for the update @Max_Delissen, very appreciated!

I would like to grab diagnostics from this test configuration so our tech team can compare the Roon logs from the MacBook Pro against the logs we received from the MacMini core already. Is this configuration still in place?