Roon stuck on identifying three files

Core Machine:
Currently running in docker on an Unraid server with 32GB of ram and a Xeon 1270v2; latest build of everything involved. Have tried setting up the core on my Windows machine with a Ryzen 5600x and 32GB ram as well as a Linux desktop with a Ryzen 2600x and 32GB of ram, both without success.

Running the desktop app on the Windows machine mentioned above.

Network is 1GB symmetrical fiber, all hardwired, running on an OPNsense box + tp-link switch.

My music is stored on the Unraid server to the tune of about 47k tracks/500GB, and I also have a copy on the Windows desktop – so I let the Core on my desktop scan that collection instead of the one on the file server, just in case, but same result. The collection on the file server is on spinning disks, the one on my personal computer is on an NVME SSD.

During the initial scan of my library, Roon gets almost all the way through it, then hangs on identifying three tracks, which process of elimination by adding music to the library folder by folder says exist in my Pop folder:

Unfortunately, whatever these problem files are doesn’t seem to show up in the ‘skipped files’ menu.

I’ve had it throw an error about not being able to contact the metadata servers, but that isn’t persistent and doesn’t seem to affect anything. Tried deleting all files <6kb in the folder, no luck; rebooted everything, no luck; removed and readded the folder, no luck; reinstalled everything, same problem.

Not sure where to go from here, so any assistance would be greatly appreciated!

You need to narrow down your search and find those three files. I’d suggest setting up a new folder, which isn’t scanned by Roon, and move half the files out of your Pop folder, into the new one. If that doesn’t resolve the problem, remove half of the remainder, and so on.

When you get to the stage where removing half the files solves the problem you’ll know that the problem files are in the set you just removed. At this stage, add half of that batch back into your Pop folder.

By moving files around in this way you’ll be able to track down the ones causing the problem.

Or perhaps read the logs normally in the roon folder under your user home folder. See the help pages for the database/ locations and you can view logs under that location

Thanks for the suggestions! I checked the logs but unfortunately didn’t find anything, so I took the Dave’s advice and slowly scooted stuff around until I eventually found the offender. Was hoping there was a faster way to pinpoint it but everything seems good now, thank you!

Yep, it does take a bit of time to track down the files that way, but it’s a reliable method. I’m glad you got it sorted.

If you search the logs for those files what does it tell you?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.