Roon stuck on "Scanning now" [Solved]

Roon start properly but the scanning process gets stuck on 10313 of 10505 files. I can use the program but the scanning process never completes. iMac with Yosemite. Thank you for your help.

Is this your initial import (the spinner in the top-right, near Search), or is this background analysis (shown on the Settings screen, with a speed selection)?

No, I have been using the program for a while. This started just about a week ago. There is a spinning wheel on the top right corner and when I click it shows that the first three steps completed but is stuck on iTunes music library import.

Hello, any more suggestions on this? The wheel keeps spinning…

Hey @gianfri – I’m going to follow up via PM, so we can get some logs from you and take a look at what’s happening here.

Sorry for the trouble!

Similar results here.
I add a local folder, either as a Watched Folder or Organized Folder.
Roon scans the folder very quickly, adds the artists/songs to the library, but stops, every time, at the same spot.
Since the process goes semi-alphabetically, it’s stopping at the beginning of the letter E, but I can’t tell for sure if it’s a specific album that’s causing Roon to get stuck.
Any help?


Hey Alex,

@kevin or I will get in touch with you shortly via PM and we’ll figure out what’s going on here.

Most likely a file in your library is causing our file scanning to hang, so if we get some logs from you, we should be able to figure it out.

Sorry for the trouble. Talk to you soon!

Found the culprit. It’s a folder with .m4a files (not protected). Deleted it, and the scanning progressed…

I have a problem that sounds a little different form the OP.

The last 3 or 4 albums I have imported to my NAS are not showing up in Roon and the spinning wheel is going in the top right corner. The library scan of my NAS completes OK but the new tracks don’t show up and the wheel keeps spinning. The message I see under “Adding Music to Library” says “Of 241 tracks, 0 added, 0 identified”.

Any ideas?

Hey @largestgasman – still having a problem here? If so, drop me a PM and we’ll take a look at your logs and figure out what’s going on.

Sorry for the trouble!

Hi Mike,

I deleted my library and installed room server - it failed to complete the import and got stuck in a different place to my original problem. I deleted the next files due to be imported and the server then set off indexing again. It did the same thing once more which I fixed the same way. After completion I re-imported the deleted files to my NAS - 1 album scanned ok and the other didn’t. I re ripped the rogue files and now all good. The newly added files I was struggling with in my original post imported without incident.

I am not at all certain why roon 1.0 imported all those files in my original installation and roon 1.1 encountered problems but I am off an running again anyway!

Hi @mike, Looks like I have the same problem as @largestgasman.
It keeps stuck on scanning. If I open the window it says “0 of 28 tracks, 0 added, 0 identified”, where the actual number of 28 keeps changing (up and down). Any ideas on how to fix this, other than deleting library and starting all over again?

Hi @sandervdp – sorry for the slow response here. I’m going to PM you now so we can get some logs and find out what’s going on.

Stand by!

We’ve got the feedback from @sandervdp, gladly he was managed to fix the issue by himself. This thread will be marked as Solved.

A post was split to a new topic: Roon stuck scanning