Roon stuck scanning

Hi @mike ,
I have the same issue here…wheel keep spinning and seems like scanning is stuck but I can access the library anyway.

Library is stored on a Synology NAS drive.
This is not the first import, I have been using this library for the past 2 years.
Any suggestion?

Thanks for reaching out, @alessandro_niola, and my sincere apologies for the delayed response here!

First, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

So we may get a clearer picture of what you’re experiencing, may I also ask you to please verify the following:

  • Are the number of tracks imported and scanned increasing or have they been sitting at that number?
  • Can you share a screenshot of your settings located in Settings > Library?
  • When did you first notice this behavior? Were there any changes to your setup when this started?


HI Dylan
Thanks for your rreply
I am running Roon 1.5 (build 334) stable (64bit).
Core installed on a 2012 Mac Mini, 16GB RAM, 256 GB ssd
Library stored on a Synology Nas 916+ with 8GB RAM
I am using different endpoints (Ipad, Auralic Aries, couple of BlueSound, a windows laptop)

Now the issue…
I thought I fixed this by removing the NAS from Roon and then re adding it. When I did that, the first scan went smooth and did not get stuck.
However, yesterday I tried a new scan and I have the same issue again, the “scanning now…” message is on and the small blue circle keep spinning.


I did also opened a new thread for this which is now marked as solved (but it’s not…):

Sorry to hear you’re still having difficulties, @alessandro_niola!

So we can better understand what may be happening here may I ask that you please provide screenshots of Settings > Storage in Roon. For the DiskStation\Music watched folder may I also ask that you please select the 3 dots next to it, choose edit, and take a screenshot of that settings screen as well?


Hi Dylan, here are the screenshots

Thanks for the screenshots, @alessandro_niola.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information. Please see the instructions below:

  1. Reboot your Core machine.
  2. Start up Roon and let the spinner go for ~5 minutes.
  3. Reboot your Core machine once more.
  4. Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and I’ll enable diagnostics on your account. When the diagnostics report is uploaded I’ll send it over to our team for analysis.

Thank you,

Hi Dylan, imdid as you said.
Rebooted the Core machine twice and let the wheel spinning 5 minutes.

Thanks @alessandro_niola.

I’ve now enabled diagnostics on your account. Once the diagnostics report reaches our servers I’ll pass it along to the team for analysis. I’ll be sure to update you once I received their feedback.


Thanks Dylan, I forgot to mention the timing…I did the first reboot at 9.40pm central EMEA time (Italy)

1 Like

Hey @alessandro_niola,

The team has investigated and we have some next steps for you. We’ve managed to trace the source of the issue to the following paths:

/Users/alessandroniola/Library/RoonMounts/RoonStorage_c6f5e7456dff07cc2f73cbae080ef34ec817ef44/Control Denied/The Fragile Art of Existence

/Users/alessandroniola/Library/RoonMounts/RoonStorage_c6f5e7456dff07cc2f73cbae080ef34ec817ef44/Badly Drawn Boy/The Hour of Bewilderbeast

Can you try moving these from your watched folders and let us know if there is any change?


thanks Dylan,
I am on vacation these days but will try that as soon as I am back home !

1 Like

Thanks @alessandro_niola,

Just let me know how it goes when you’re able to give it a try. Enjoy your vacation! :sunglasses:


Hi Dylan.
I removed those 2 folders and started a new scan. Everything went well, the scan was successfullt finalized.
Now as you my guess, here is my next question:
How can I prevent this from happening again? What was wrong with the 2 folders I deleted?

Hey @alessandro_niola — Thanks for giving that a try and reporting back!

Just to confirm, did you delete these folders or just move them? If you still have them would you be able to zip them up and share them with us using a shared dropbox link? If you don’t have Dropbox or need another way to send the media, just let me know.


HI Dylan

You should be able to see these folders here : [link removed by support]

Thanks, @alessandro_niola!

I just wanted to confirm the folders have been downloaded and passed over to the team for further investigation.


A post was split to a new topic: Roon scanning not progressing

Hey @alessandro_niola,

Our senior development team is doing some further investigation here, and they are hoping you’d be able to perform a quick test for us.

Add the folders that you previously removed back into your Roon watched folder. Does the scanning behavior occur once more? If so, you can remove the folders once again and just let us know the results.


A post was split to a new topic: Watched folder infinitely scanning