Roon suddenly Awol and won't connect

Inexplicably (to me) I can no longer connect to Roon. I have the Roon Server on a sonictranporter. I can’t connect either through the desktop app or the iOS. I’ve gone onto the the sonicobiter and trier to clear the cache stop and restart the Roon server. I’ve also restarted my MacBook. Still cannot connect. I’ll see the opening page with the quote, then the flashing Roon icon, and then the app quits,

Can’t imagine what might be going on. The sonic transporter is on my network and I can see the music files on it via Finder.


Don’t know anything about the device but can you try reinstalling roon on it?

Hello @soyka0120,

I have gone ahead and enabled diagnostics mode for your account and am reviewing the logs for it. I noticed that one file keeps popping up in the diagnostics for your SonicTransporter:
[analysis] analyzing trackid=115530290 url=/storage/music/flac/02 Dave Brubeck Trio, Gerry Mulligan - Mexican Jumping Bean.aiff

Can you please try moving this file out of your watched directory and reboot the SonicTransporter, your Macbook and all networking gear? Do not delete this file just yet, but move it out of your watched location and then if it is the offending file causing such issues I kindly request for you to send it to us for QA to take a look.


Ok, i don’t see a directory labeled “Watched.” Where might I locate it?


@noris means the directory that Roon is watching for your music files.

Well, we’re halfway there. Removed the file, rebooted the system, and could connect…However, Roon still quits. Oddly, I can select something to play, the app quits shortly thereafter, but the music continues to play.

I tried to attach the file here but it does not accept aiff files. I’ll try to send it to you via email.


Hmm, the file is getting hung up in my outbox for some reason (which perhaps indicates that something odd is going on). Is there a dropbox or someplace else I can send the file to? @support

Where did you get the file from? Did you buy it or rip it yourself?

Ripped it myself using XLD. And for what difference it makes, from a legitimate CD I own.

I was asking as there is a problem with the file, you own the source, perhaps ripping it again might be a way around your problem with the file.
I wasn’t impuning your honesty in ownership.

No, I didn’t take it that way at all. Just wanted to emphasize that the corruption couldn’t have been inherent in the source (couldn’t, right?). Like everyone else here I’ve been ripping my library and would like to know why this particular file should be causing a problem using a standard application (XLD). I assume something happened during the ripping process.

Could be a power spike or the cat jumped on the PC :slightly_smiling_face: or anything really.

Hello @soyka0120,

Glad to hear that moving that file has partly resolved the issue! I have PM’d you instructions on how to upload that file to our servers for QA to take a look at. I am taking a look at the new diagnostics from your machine, I see that it is able to play a Radio Station but there appears to be a whole lot of audio analysis happening in the background. I would wait for the spinner in the top-right corner to finish analysis and then try playback again.


uploaded the file:
02 Dave Brubeck Trio, Gerry Mulligan - Mexican Jumping Bean.aiff

Have tried to reopen Roon to play music files (as opposed to streaming radio). I get the message “Transport failed to load media” and then shortly thereafter the app closes.

Hello @soyka0120,

Thanks for uploading that file, I am not seeing any crashes on the SonicTransporter side of things so I am thinking this could be due to the Roon Remote this time around. Can I please ask you to manually send us the logs from your Macbook? You can use these instructions to locate the logs and you can upload them to the same place you sent the media file, just please be sure to let me know the name of the logs after you have uploaded them so I can locate in the server.


Okay, uploaded as soyka

Hello @soyka0120,

It looks like the same file is causing issues on your Roon Remote:

01/08 12:46:36 Trace: [analysis] analyzing trackid=86435890 url=/Volumes/OWC HD/Music/iTunes/iTunes Media/Music/Unknown Artist/Unknown Album/02 Dave Brubeck Trio, Gerry Mulligan - Mexican Jumping Bean.aiff
01/08 12:46:36 Debug: [library/settings] updating track LibraryTrack[86435890, Various Artists, Banditos, The Jesus and Mary Chain - Unknown Artist - Unknown Album - 02 Dave Brubeck Trio, Gerry Mulligan - Mexican Jumping Bean IsAvailable=True IsDeleted=False ] (track False clumping False)
01/08 12:46:36 Trace: [library/compute] computing 1 tracks

Have you made sure to remove it from your OWC HD?


Removed the file from the backup hard drive (should have thought of that). Re-ripped the offending track and all is working well again. Thanks for the quick response to solving this. Appreciate it.


Happy to help @soyka0120! Thanks again for contacting support and hope you have an enjoyable listening experience :headphones:!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.