Roon suddenly won't run

Running MacOS High Sierra 10.13.6. Roon worked fine until 3 days ago. Now it won’t open. Icon in iMac dock bounces, then Roon shows one of the witty historic quotes, then it shuts down.

In last three days, I purchased MyCloudEx2Ultra NAS. Moved all music to the NAS. Roon worked fine for 2 days.

Recent things I did were: I updated Sonos library. I moved Roon music from one NAS folder to another. Maybe ran Avast antivirus software. Otherwise I did nothing out of the ordinary.

Cut and pasted this into terminal: /Applications/

Answer was this: Got a SIGSEGV while executing native code. This usually indicates

a fatal error in the mono runtime or one of the native libraries

used by your application.

What does that mean? What do I need to do? Should I download and re-install Roon?

Hello @Theodore_Grabow,

I have a few questions:

  • Do you have current backups of your Roon Database?
  • Have you tried rebooting your Mac and the behavior is still the same?
  • Is Roon by any chance quarantined as a false-positive by Avast?
  • Can you please send the Logs from your machine to us using these instructions?
    If you don’t have Google Drive or Dropbox just let me know and I can provide an alternate upload method.


I have backups of Roon Database. I have rebooted Mac and router. No change in behavior.

I cannot figure out Avast false-positive issue. Been working on that but online directions look different than my Avast.

Working on Logs. Not sure about Google Drive or Dropbox.

Hello @Theodore_Grabow,

I have PM’d you on how to get the logs over to us just now. Please send those logs over first and then you can use these instructions to generate a new database and restore from the backup you have to get you up and running again:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location:
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart the Roon App to generate a new Roon folder
  • Restore from Backup