Roon Support for MacOS Ventura 13 Beta

Roon Core Machine

Mac Studio M1 Max
MacOS Ventura 13 Beta (22A5311f)
32GB Ram

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

70K

Description of Issue

Roon crashes or locks up under the latest MacOS Ventura Beta. I appreciate the Beta software may not be supported but I thought worth advising that it is not working as expected. As far as I am aware there are no changes to the functionality of MacOS Ventura which should prevent Roon from loading.

Regards

Keith

2 Likes

Roon server or just roon install?

Just a Roon install, been working well until installing beta.

What version is roon ? Have you tried a reinstall and by that I mean removing or renaming the ~/Library/Roon folder as well as the app itself?

I just tried it agin, last time I tried was yesterday evening and it seems to be working now. I’ll continue to monitor it.

Version is 1021.

Regards

I am running Roon version 1.8 (build 1021) stable on MacOS 13.0 Ventura Public Beta 4 (22A5331f).

From the Settings>Audio page, I can no longer choose my MacBook Pro Speakers or any externally connected sound interface (i.e. Scarlett 4i4 USB, Dell monitor, etc…). I can only see and choose network devices - i.e. Airplay, Chromecast streaming, etc…

Everything was working fine in the previous MacOS 13.0 Ventura Public Beta 3 (22A5321d). I have tried a complete MacBook and Roon ROCK server reboot. Still no builtin sound sources are available to play music on.

Find Roon OS does not work now and gets stuck on: Searching for Roon OS Core…

Please help!

Thanks!

Assuming you have made a recent backup of Roon, you should be able to download and (re)install the latest version of Roon.
[Roon works fine here with Ventura public beta but with Roon Core on Mac]

Check the firewall? You may need to allow Roon network access.

It’s working fine for me