Roon/Synology Hangs while identifying

Hi @support, I have searched for a solution to this problem but have been unable to find it. I am running Roon on Synology DS718+, when I attempt to import my albums Roon hangs while conducting the identification step. Same thing happens with tracks/albums that are imported from Tidal. Can you help?

Thank you for the report @Gealcock, the feedback is appreciated!

Moving forward, I did some research into the device currently hosting your Roon core and according to the spec sheet, it is making use of a Intel Celeron J3455. My concern is that this unit, the DS718+, is falling below our recommend specs and as such you could be feeling the affects of having RoonServer running on a slower CPU.

During your troubleshooting have you by chance tried hosting your Roon core on a different devices to see if you run into the same behavior?

-Eric

Ok thanks. I had read postings where that configuration had worked for other users.

Would a lower cpu speed not just cause it to be slow vs hang indefintely?

Hi @Gealcock ---- We can certainly enable diagnostics on your account and take a look at the Roon logs that come attached to the report to verify if there is potentially something else causing this behavior :microscope: I will go ahead and enable this feature now and the next time Roon is active on your core machine the diagnostics report should be uploaded to our serves automatically. I will confirm when we have it.

Additionally, in regard to the lower CPU, as per our knowledge base the types of behavior we would expect to see with a slower processor in place are the following:

  • Stuttering or dropouts in audio playback
  • Slow response for searching
  • Slow loading of artist, album, composer, and work pages
  • Longer startup and connection times for remotes
  • Slower audio analysis for normalization/crossfading/other
  • Slower import of new music

-Eric

Ok thanks Eric, that is great. I am traveling for work and turned the core off before leaving. I am back Wednesday night and will turn on then.

1 Like

I have started the core again, hopefully and easy fix.

Hi @Gealcock ----- Thank you for the follow up, very appreciated!

Confirming that the mentioned diagnostics report has been received and is now with our techs for evaluation. Once your ticket has been updated and passed back I will be sure to share the team’s thoughts/findings with you asap. Your continued patience is very appreciated!

-Eric

Hi @Gealcock ----- Thank you for your patience while our techs have been reviewing the received diagnostics report from your system.

Upon further investigation our techs have noted that they are seeing traces in your Roon logs that indicate that there are “networking error” warnings during the identification process. In light of this discovery the team has asked if would kindly please provide the details of your network configuration/topology, being sure to provide insight into any network hardware you are currently implementing.

-Eric

Thanks Eric.

Hardware is a Pakedge RE-2 Router with Pakedge SE-8 switch. Synology NAS is wired into the switch.

In addition to the NAS, I have a control 4 system, sonos, apple tv, and amplifi ubiquti wifi plugged into the switch.

Modem is a Bell Homehub 2000, which has had the the router disabled. Wifi is off of an amplifi ubiquiti mesh network.

Roon Core is installed on the NAS which is hardwired, Roon app is installed on my MAC which is connected via wireless.

If you give me specifics of what additional details you need, I can provide them.

Thanks for the follow up and providing the requested information, @Gealcock! Very appreciated!

Whenever we are investigating a potential issue with a user’s environment, I always recommend using the process of elimination. Taking complexity out of the chain of communication and then adding each “link” back in one at a time to see where things succeed and where they fail.

With the above in mind I would like you to please test (temporarily) with NAS mounted directly to the Pakedge RE-2 Router. If possible it would be great to also have the mentioned MAC remote mounted to the router as well. So the “test configuration” should be:

Bell Homehub 2000 (modem) > ethernet > Pakedge RE-2 Router > ethernet > NAS.

Bell Homehub 2000 (modem) > ethernet > Pakedge RE-2 Router > ethernet > MAC remote.

Looking forward to hearing your observations!
-Eric

Thanks - just made that change… still not working. :frowning:

Thank you for getting back to me with the results of the proposed troubleshooting exercise @Gealcock, I am sorry to hear that the test run did not yield a more positive outcome.

Continuing forward, I have re-enabled diagnostics on your account so we can have a closer look into what the system was doing when the test has been performed. I will confirm when the new report has been received and once it has been evaluated by our techs I will share their thoughts/findings with you ASAP.

-Eric

UPDATE: That was quick. The report has just hit our servers, passing over to the team for analysis.

Thanks Eric - any feedback?

I just got billed for the year subscription… and obviously if my config can’t be made to work properly, I need to cancel it and get refunded. Hopefully they have solved.

Hi @Eric, checking to see if there has been any insight? Are there any country specific issues, I live in Canada? I notice when I ping the metadata server in the log, it times out regardless of wether I ping it from my home network, or through my iPhone cellular network or other.

Hi @Gealcock ----- Thank you for touching base with me and more importantly, thank you for your patience.

In regard to your most recent observation and based on the the team’s findings mentioned in my previous I believe this issue is manifesting itself in one or two places (or potentially a combo of both): the device hosting the core and/or the performance of the network.

Network troubleshooting can prove to be tedious and I would strongly recommend looking into the core machine first as this will be easier to test. I would recommend the following:

  • Before anything please make a backup of your current DB.

  • Take RoonServer offline and temporarily hosted your core on another device. I would recommend the MAC you referenced above as a good candidate for this test.

  • Point the new MAC core at the NAS so it can start importing music and confirm if the behavior presents itself again.

If the issue does happen to present itself again with the above configuration in place please reframe from taking it offline as I would like to enable diagnostics first so we can determine if we there are same network errors we saw in the previous report.

-Eric

Thanks Eric, will try the changes and get back with results. Wasn’t clear on the network issues… I am in Montreal today, and tried pinging the metadata server from a completely different network and it still times out. Are we sure there is nothing geo specific blocking access from Canada?

Hi @Eric - running the server on the Mac fixes the issue. Any idea on what could be preventing the synology NAS from communicating with the Roon Metadata server? @crieke anything you have ever come across?

Would really prefer to run this off the NAS.

Hi Geoffrey,
can you specify how the network settings for your Diskstation are set?
I am especially interested, if you manually set the IP configuration or if it is set by DHCP.
Is the Synology vSwitch feature enabled?
Are you using multiple ethernet connections of the diskstation or just 1?
Did you made changes to any dns settings (router/diskstation)?

Hi Chris,

Network configuration is set by DHCP
vSwitch is not enabled
I did have multiple ethernet connections enabled but as part of the problem solving have turned that off and am using 1 now.
I just reset the NAS network configuration to put everything back at default, still won’t reach metadata server.
Nothing unique in router, Roon has no issues running when I use my Mac as the Roon server connecting through the same router.

Hopefully you have an idea…

I have sent you a PM.