Roon takes over all volume control

(Matthew) #1

I have Roon set to “Use Device Controls” for the Volume Control Mode setting. Roon seems to take over all volume control, within and without Roon, on my computer. My path is Roon -> DietPi RAATServer -> Zeppelin Air. For instance, I listen to Roon for a bit at a comfortable volum, stop playing, close Roon. Open Spotify, playing through same dietpi (also airplay enabled) and the max volume I can play is where I left off in Roon.

I can reopen Roon and use Roon to control the volume for the device. Problem is within a couple minutes Roon loses contact with the DietPi and I’m left with no volume control. So then I have to disconnect it on Airplay and reenable it in Roon.

Is there any way to keep Roon from taking over the volume control outside of Roon? Even if I set volume control to “Fixed” it seems to be influencing the signal (in this case, limiting the volume).

This isn’t the first issue I’ve had with volume control in Roon - Is there any way to complete disable Roon’s influence on volume?

(Matthew) #2

Replying to my own thread after I did a little more sleuthing. The Roon volume control influences the DiePit’s ALSO Mixer’s digital audio gain. I’d prefer to have one volume control (the amp itself) rather than the macbook’s, the digital audio gain, and the amp’s.

Anyone familiar with this and know how to bypass all these digital volume controls? Thanks.

(Martin Webster) #3

Under Device Settings > Volume Control Mode select Fixed Volume. This disables volume controls in Roon; volume is controlled solely by your amplifier.

(Joachim F) #4

Bump :slight_smile:

Also ran into this issue with Roon and raspotify in coexistence on the same dietpi device. Roon acts like master volume for the spotify connect volume. Where the volume for Spotify is limited to a max where it was left of from the last Roon session. My use case is Raspberry 3 with an iqaudio soundcard.

@Dan_Knight Any way to separate the raspotify volume from Roon’s control?

Thanks Joachim

(Dan Knight) #5

Not that i’am aware of, as Roon is changing the master volume at a hardware level (similar to alsamixer).
Roon talks directly to the audio hardware, ignoring any asound.conf settings. By design I believe to improve audio quality.

(Joachim F) #6

Thanks for the quick reply!

I see, I use Roon+Tidal for audio quality reasons in the main rig. Rest of family wants Spotify for its convenience and superior app and UI, for good reason. I find myself using Spotify more and more outside the house…

Running chromecasts in most rooms for control from Roon and Spotify which works nicely. But don’t want to switch to a chromecast in the main rig for audio quality reasons.

The search goes on then.

Thanks Joachim

(Yiannis Kouropalatis) #7

Hi Joachim,

Not sure if this volume control issue is still there with Dietpi… I understand that if you try to use Spotify then volume is limited by what Roon has left at any give time. Did I understand this correctly?
If so then I would recommend you try volumio. I have been using it on one of my Allo Digi devices and it works without the problem you mention: Roon bridge installed via SSH on the side of volumio. I have installed the Spotify plugin in volumio. Volume control is fine (Roon does not affect Spotify and visa versa). The limitation with this approach is that you cannot use the volumio eq as it conflicts with Roon. If you don’t install the volumio EQ then you have no problem. Roon DSP works without issues.

Maybe this issue has been resolved with Dietpi in the meantime?
Cheers

(Joachim F) #8

Thanks Yiannis, I will give your suggestion a try.