Roon takes quite long to initialize when started

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro 64-bit, i7 7700, 32GB RAM, roon database stored on SSD, roon 1.7 build 505

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Music stored on network share connected via gigabit Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Local system output

Description Of Issue

roon takes about 1 minute to initialize when started, during this time I can only watch the busy screen and wait until the main screen comes on… I just wanted to know if this is normal because my computer has enough hardware resources and other music players (foobar2000, MusicBee, JRiver) only take a fraction of that time to start while pointing to the same network share holding my music library. .
I know roon is loading its database on startup, but that should not take that long when stored on an SSD. Is there anything I can do to avoid waiting every time I start roon?
My library contains 262K tracks.


seems normal. I have about 112,000 tracks. Probably takes a minute or so to fully load. Running on Win 10 (64) machine with SSD. Not as fast as loading foobar2000 pointed at same files. But as you said, a large database is not being loaded with foobar2000.

Hi @Adrian_Matala,

A 262K library is quite large, a minute or so doesn’t seem too far-fetched to me. If you want, you can move your database over to RoonServer and have this start when Windows boots, that way your database will load ahead of time. You can also keep the Roon app installed on the same PC but use it just as a client instead of the “All-in-one” App.

Thanks for the feeback. I also noticed that roon is using 3.2 GB RAM on my PC when fully loaded (while other apps only use a few hundred MB) so I assumed it’s from the library getting loaded synchronously at startup but didn’t know if it’s normal o take that long.
I probably need to change my habits and not open and close roon as I need it like I do with other apps, but keep it open all the time… An option to minimize to system tray instead of closing would also help avoid closing it by reflex and then having to wait again when restarting it.

Set it to startup on reboot and develop a taste for coffee :shushing_face:

That is a pretty big library, mines 150k a minute sounds normal, mine churns the disc for a while after the first screen appears.

I reboot virtually every day, we are prone to thunderstorms in Johannesburg so everything gets unplugged at night

JRIVER I don’t think loads the library it just queries it hence it only has to start itself

After the first screen apprears it’s all good, detecting changes in the library is still active in the background for a while but that doesn’t bother me in any way. Aslo, finding those changes is quite fast now because I have divided my library into mutiple directories, one for each letter and added each one separately to roon so it can scan multiple directories in parallel.
Detecting changes when using one single directory for my whole library used to be quite slow also, but with the current config it never takes more than a couple of minutes at most (when I add many hundreds of new files).

Hi @Adrian_Matala,

As I mentioned you can use RoonServer + Roon app to avoid this issue since RoonServer will keep running in the background and the Roon app is only a client at that point. Or you could check out an app which minimizes apps to the system tray, I use RBTray.

I have installed the RoonServer as you suggested and this seems much better for me indeed as I can keep the server running in the background and open and close the app as I need it. Opening the app is instant now so no more annoying delays. Thanks a lot for the suggestion, I hadn’t thought of that before. :smiley:

1 Like

Awesome, glad to hear that RoonServer worked out for you @Adrian_Matala!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.