Roon tells me to check QOBUZ

Roon Core Machine

Alienware M-51 laptop

Networking Gear & Setup Details

Netgear 25 Nighthawk

Connected Audio Devices

Sonic Orbiter MicroRendu

Number of Tracks in Library

No idea

Description of Issue

When I open Roon to play an album it tells me to check with QOBUZ. I just renewed my subscription today (see below screenshot). How long do I have to wait before Roon “accepts” that I have a current Qobuz subscription?

In Roon, logout of Qobuz and log back in. See if that kicks it into behaving.

Settings → Services

Or log out. Reboot. Restart roon and then log back in.

I did that. Still not working.
But I found yet another clue (See screenshot). Perhaps that is the problem?

I removed your email address that was shown.

Easily done but are you sure you are using same email you used to renew your subscription with?
And you should edit that screenshot to hide your actual email address on this public forum.

yes, I am using the same email address… and there is no help at Qobuz until Tuesday…

I sent this to the French Slouches:

You could try posting on the Qobuz issues thread on Audiophile Style, which is followed by some members of the Qobuz staff. You might not get any faster response, but somebody else there might have some ideas.

It is pity, Claus. I have no problems to login to Qobuz. Did you try to login via Qobuz app (on PC, on smartphone) and Qobuz website without success?


I can log in on my iPad using the Qobuz app, but when I try the Roon app on the same iPad it gives me the following message:

“Unable to start streaming. Check your Qobuz account and try again”.

So it seems to be “A Riddle wrapped inside an Enigma” as Churchill famously said.

On the PC I get the error message above when I try to login to the website.

Hey @Claus_Jensen1
Would you try the following, which has worked for me in the past.
If not already done, change the DNS server in your router to either Cloudflare or Google DNS server
Then reboot everything: router and all network components as well as the core machine.
Good luck!

Claus, so it seems to works with mobile connection (Mobilfunk) but not with landline/fixed network (Festnetz)?

It seems that signing in to Roon is also weird. It keeps telling me to reset my password, and when I do that (using exactly the same password) I am able to sign in.


I tried changing the DNS address to and then rebooting. Still same result.


Not sure I understand? My internet access is from Xfinity/Comcrap and it is with a cable…

I only suggested to test the login with internet connection via cable and via mobile internet connection.


I’m sorry to hear that.
Is there a firewall or any security settings for your modem/router that you can disable temporarily?
Disable only during the login process, if the login was successful you can re-enable everything.


I tried that and still no joy.

To test my system without Qobuz, I downloaded and installed Spotify. It works and is extremely user friendly with a great iPad app,
I wonder why Roon does not partner with Spotify. That would be “A marriage made in Heaven”,
In any event I am cancelling Qobuz and Roon!
Thanks for all your help and byby.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.