Roon/TIDAL integration problems

Core Machine (Operating system/System info/Roon build number)

Core: Roon Server, build 528
Mac mini (late 2014), CPU i5, 8 GB RAM, macOS Catalina (10.15.3)

Remote: Roon, build 528
Mac Pro (Early 2015), 13-inch, CPU i5, 8 GB RAM, macOS Catalina (10.15.4)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Mac mini —[1 Gbit Ethernet] —> Switch —[1 Gbit Ethernet] —> Router
Router: Synology RT2600
Switch: ZyXEL GS1900-8

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mac mini —[WiFi]—> Chromecast Audio —[Optical]—> DAC

Description Of Issue


I’m a happy Roon user since many years ago. Quite recently, I signed up for a TIDAL subscription, and I have been very pleased with the Roon/TIDAL experience.

However, a few days ago I started to get serious problems with the TIDAL integration with Roon.

Yesterday I needed to re-login to TIDAL. After following a tip about shutting down Roon Server (installed on a Mac mini) and remove the Roon cache folder, everything worked for a short period. While I was playing my TIDAL playlist (with no local content) I noticed problems when I was browsing around in the Roon remote GUI on my Mac Pro. I also experienced the same problem when I used Roon Remote on my iPhone.

The problems were that when I searched, I only got local content, nothing from TIDAL. And when I went to the Overview page I couldn’t see anything. The page was blank, except the Roon icon flashing. However, I could go to the Playlist page and see the TIDAL playlists. So, in summary, I couldn’t see any TIDAL content, but I could play TIDAL content in my TIDAL playlists.

Today, the problem got worse. I couldn’t continue to play my queue, which was the content of my TIDAL playlist. And when I tried to browse around in the GUI, Roon started flashing “Error loading page. Please check your network”.

So at that time I ran an Internet speed connection test on my Mac mini (where Roon Server is installed), and I had roughly 240 Mbit both up- and download, and 4 ms response time.

And now in the evening, when I tried to play some music again, Roon didn’t show any TIDAL content. The overview page was blank, and after a while Roon told me I wasn’t logged into TIDAL. Now I have tried to log in at least three times with the same result. The webpage shows that I’ve successfully connected my TIDAL account, but in the Roon application I’m still logged out.

The $4 for 4 months offer is overwhelming Tidal’s servers? Just speculating, but there seem to be a lot of roon/tidal problem reports lately.

3 posts were split to a new topic: TIDAL issues - Play stuck at 0:00

Hi @samoa,

Welcome to the Roon forum!

Can I please ask that you reboot your Networking Gear, Roon Server and Roon Remotes to see if that helps with this behavior?

I looked this switch up and it seems to be a managed switch. Managed switches are sometimes trickier to configure right with Roon (please see Networking Best Practices for more information in this regard).

If the reboot doesn’t sort the issue out, can you try bypassing the switch and have the Core connected directly to the router? That should help us troubleshoot if the switch is part of the issue or if the issue is elsewhere.

Hi @noris,

The problem disappeared when I installed the latest version of macOS on my Mac mini where I run my Roon Server. I’m not sure why that worked and it didn’t work when I restarted the Roon Server earlier, but for now I’m happy.

Thanks for the help!

1 Like

Glad to hear the update helped @samoa! Since the issue is resolved, I will mark this thread as [solved] but if you have further difficulties, just let us know, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.