Roon to devialet pro problems

Dear @support
I have recently installed a new sonic transporter i5 and am streaming music to a devialet 140 pro with CI board (firmware 13.0, dos 2.2.2) via roon Air (none of the previous devialet air drivers are installed). I am getting dropouts every 3-4 seconds. The music continues to play just with with short drops that repeat at ~4 sec intervals. However, if I instead use the airplay mode input on the devialet, the playback is smooth without the drops. I have tried low res tidal and my flac files (both normal and high res).

My setup consist of the sonic transporter and devialet 140 pro connected via wired ethernet through dlink dir890l router. My music files are on a usb ssd attached to the sonic transporter.

any help would be appreciated.

The difference between airplay and Devialet AIR is a ton of data, so this would point to a network issue. As your router is quite new the first step would be to make sure the ethernet cables are high quality and that the devices are linked at at least 100 full duplex. You can probably confirm this in the router GUI. Also check that no one is streaming 4K movies through the same router while you’re trying to listen to music.

Hi @samysound,

As MJB mentioned above, it sounds like there may be some networking difficulties at play here. Is there any other networking hardware in use (switches, powerline adapters, etc.)?

Do you experience this type of behavior when playing to any other endpoint besides the Devialet?

Hi Dylan and MJB,
Many thanks for the replies. The only switch used is the one built into my dlink router. I had my whole house wired with Ethernet cable about 5 years ago so no use of any power line adapters. Also no other streaming or use of major bandwidth at the same time.

The only other endpoint I have is my cell phone (google pixel 2) which I am also using as a remote. If I use my phone as an endpoint (connected via WiFi) then I get smooth playback. Also if I attach my music to my router via USB hard disk and use as a Nas streaming to my devialet via upnp, I get smooth playback as well.

Please let me know your thoughts and many thanks for your help. @support @dylan

Also, I tried bypassing the built in switch in my router with a trend micro switch and am now getting “transport device in use” error when trying to play to the devilaet end point so am not able to test it out. I tried rebooting the core and power disconnect restart on the devialet.

@support bump

Hi @samysound,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi @dylan @support

I ran the system 9:21am to 9:25am PST this monring and had the same drops/stutters.
Many thanks for your help!

@support also noticed that the devialet cycles between showing an IP and showing no IP in it’s info menu. Not sure if this is normal or what is causing the problems with playback. See images below

That’s not good, and probably the cause of your problems. Try replacing the Ethernet cable.

Thanks for the timestamps, @samysound.

I’ve enabled diagnostics so the team can take a look.

The Devialet showing no IP address definitely sounds like you may be experiencing some networking issues. As MJB suggested, definitely try a different Ethernet cable and see if there is any change.

When the device is in this state, does that seem to coincide with the issues you see when using Roon? Can you play to it from another source while it’s in that state?

Yep try another cable, or changing slots on your router. Ethernet connection on Devialets is rock solid normally (unlike wifi).

Hi all
I moved the devilaet right next to the router and used a a different tested patch cable to attach to my router and still get the same problem. I also bypassed the internal switch in my router with a trend micro unmanaged switch and get the same issues. I am starting to suspect that the devialet is defective. Devialet customer support is tedious and slow to deal with (preout features are not working either)… Many thanks to @dylan @support and roon forum members for being so responsive.

Maybe reflash the Devialet firmware? Do you have the possibility to test WIFI as well? Have you configured your Devialet with a static IP on the “configurator” ? If yes try DHCP.

yes, I have tried refreshed firmware and loaded new config files. Currently using DHCP in the devialet config. Tried setting my router to reserve the IP as well. I am having issues with other aspects of the devialet as well. My unit is supposed to have the preout board installed but does not seem to recognize it (or, perhaps the factory forgot to put it in).

Hi @samysound,

Definitely let us know what Devialet support has to say and please feel free to reach out if you have any further questions for us!

Hi @dylan
will do. did the logs give any insight into possible issues?

Check whether the LED at both the router (or switch) and the device (if it has an Ethernet LED) flashes normally.

Hi @samysound,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need logs from your Core machine.