Roon tracks rapidly skipping (yup, that issue!)

Roon Core Machine

Windows 10 Laptop 32gb ram
Intel Core i7 6820HQ
All devices running latest Roon versions

Networking Gear & Setup Details

BGW320-505 modem/router
AT&T in Los Angeles
No VPN etc

Connected Audio Devices

Relevant to this issue:

Number of Tracks in Library

~15k tracks?

Description of Issue

The dreaded “Roon rapidly skips tracks without playback” issue. I’ve done my best to read through as many cases of this as I could here, but they all seem to trail off with no resolution, resolve via some mysterious deus ex machina or workaround, or were resolved by doing things I’ve tried which haven’t worked for me.

I’ve experienced it before on other devices and was always able to get sorted out one way or another - changing exclusive mode settings, rebooting, etc. I even got everything working on another UCX II unit that did the same thing at first. But I’m stuck on this one.


  • Effects Tidal tracks and local tracks
  • Only happens on the UCX using WASAPI driver, does not happen with ASIO driver (same device / same outputs). I can use ASIO to sidestep it but would like to get everything working instead of dodging
  • Exclusive mode is OFF, but happens whether it’s on or off
  • Network or file access issues seem to be ruled out because all I need to do is switch to ASIO or literally any other output on my other devices and streamed and local files play fine
  • Happens whether I directly choose the output I want on the UCX or set Roon’s output to “System”, where the UCX is set as the default

Bonus item - no matter what I do, including setting Volume Control to “Device Volume,” I cannot get the system volume in control while using the UCX. When I’m working during the day I use touch pads and use volume control gestures and have always been able to get this to work, including on the previous UCX.

Any thoughts / pointers on either issue?

@Hazen, a couple of thoughts.

First, I have AT&T fiber, but use an older Pace gateway. One issue that I had for months with AT&T was AT&T’s DNS service. I have a second router and mesh system in my network due to the older and less capable WiFi in the Pace gateway, and was able to change my DNS in my personal router to use Google DNS, which improved all of my network functions. I am not sure if you are allowed to change this in the BGW320 gateway.

Second, is your W10 Core connected to your BGW320 using an Ethernet cable or via WiFi? If on WiFi, can you try connecting it with an Ethernet cable? Some of the symptoms you describe may related to your network and this could be useful to eliminate a variable or two.

Thanks Robert.

Looks like DNS settings are read only on this router.

I live in a new apartment building so we have very fast fiber, but they happen to have used the wrong ethernet cables in the walls of the units (according to a visiting ATT tech), which is a comical bottleneck. My wifi speeds crush it, so I currently use wifi. I haven’t even used an ethernet cable on my core laptop, it doesn’t have a port and I don’t have an adapter!

Although I’m skeptical since the exact same tracks, connections, etc work on everything except the wasapi driver on the UCX, I’d also love to check that off the troubleshooting list. I’ll see if I can scrounge up an adapter.


Honestly, it doesn’t take much to do gigabit. It could be wrong terminations, it could be poor termination, it could be a number of things but “wrong cable” just seems suspect to me. Unless they only ran 4 conductor and then, well, that’s not ethernet :slight_smile:

Anyway, if this really is the fault of the cable the contractor should come back and redo it. They can use the old wire to pull the new wire through the well. Good luck.

Yea trust me, I was confused by that comment from the tech. And I’ve tried to get building management to change it. No such luck.

Nevertheless, when I’m switching to my Focusrite interface using wasapi or asio drivers, or switching to asio on the UCX, any of three Chromecasts, a Raspberry Pi, SMSL and Schiit dacs, my phone, my computer monitor speakers…literally any and all other output devices and the skipping issue doesn’t happen, I have to imagine the likelihood of it being the wifi is pretty low. No?

The magic handle has been found and jiggled.

Changed the sample rate on the RME from 44.1KHz to 88.2KHz, which is what I normally have it on for my DAW.

Watched the audio settings in Roon as I did it. All of the RME’s outputs reloaded, resetting their manually entered names. Enabled and picked the main out w/ wasapi driver, plays perfectly with no skipping.

Figured out the volume control via Windows too:



Not how I remember it in past situations but, can’t complain.

Thanks all.

@Hazen, shall we mark this as solved?

Yes, please and thanks :pray:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.