Roon truncates 24bit to 16bit on my new Pioneer U-05 (ASIO) [Resolved]


just got my U-05 yesterday. Does anyone have an idee why 24bit ist truncated to 16bit?

My Sony UDA-1 does not do this …



I’ve seen the same behaviour on my asio device. I switched to wasapi for the time being, this solved the problem. If there’s more people seeing this it may be a bug.

Thanks for your info. I tested wasapi myself. 192/24 works but then DSD gets converted to PCM. So at the moment I switch between asio & wasapi depending on what I’m playing … Can remember that Roon 1.2 had the same problem for awhile.

Hi @Michael_Kolletzki ----- Thank you for the report and my apologies for the troubles.

If my assumption is correct, it sounds like your are running on a Windows based device. Can you try enabling the work around drivers that misreport device capabilities feature under the audio settings to see if that triggers a change in behavior?


Hi Eric, sorry was at work all week and just got home. I can not see any option with work around drivers under the audio settings … I am running Windows10 on a Intel NUC6i5 …

The ASIO drivers I use have their own setup application where I can set what bit depth the ASIO drivers will use. Maybe the Pioneer ASIO drivers do as well?

That’s a good idea. But sadly pioneer doesn’t have a setup application …

Is there a config file maybe? Asking because I couldn’t find any information about those ASIO drivers on the net. Or maybe my searching is defective today, LOL.

On the WASAPI can you use DOP to get DSD to the Pioneer?

I’lll try to find a config file if there ist one. Using WASAPI I only get sound playing DSD if I convert to PCM (1st option). I really don’t understand why hardly anybody has a Pioneer U-05. It’s a great DAC at the price with ES9016 inside.
Why doesn’t roon give me the option to decide when it converts? I mean streaming to the my sonos play 1 roon does a great job but using the Pioneer U-05 DAC (that connects to my yamaha a-s1000) it would be nice to be able to decide that conversion is not needed.

Hi @Michael_Kolletzki ---- Thank you for your patience and my apologies for the slow response here.

Moving forward, Can you give us a little more information about the ASIO driver? I didn’t see it on the Pioneer website, but it’s possible I missed it.

For the last screenshot, can you show us your WASAPI settings? What are you using for DSD Playback Strategy?


Hello @Eric, I’m only home on the weekends so it’s no problem if “we” take awhile :wink: I’m using the normal Pioneer Drivers (ASIO/WASAPI) for my DAC. You can find the driver under:
When using WASPI for DSD playback the only why i get sound is with the settings in the following pictures. Both other DSD Strategys deliver no sound … I’m pretty sure I have tried most possible setting. Thanks for your help. Mike

Hi @Michael_Kolletzki ----- Thank you for the follow up and verifying that information for me, as well as providing the requested screenshots :thumbsup:

Moving forward, may I ask you to please try with the following setting engaged while using the WASAPI driver:

  1. “Work around drivers that misreport device capabilities”

  2. DSD Playback strategy = “DoP”

Looking forward to your feedback!


Just tried it again, but like I wrote before, the only way I get sound playing DSD with WASAPI is when I convert to PCM.

On Head Fi, there was someone who posted a screen pic of the Pioneer ASIO setup.

With my Asus, one way I can get to the ASIO panel is to have it selected as the device in JRiver, Select Device Settings, select Open Driver Control Panel.

1 Like

Thanks @Rugby -> That does the trick. I installed JRiver and changed the settings for the ASIO Driver (same settings screen as in your post). Now Roon does not downsample my 24-192 files anymore … this means that everybody that has a Pioneer U-05 neads Jriver to make Roon play 24-192 without downsampling with ASIO :wink: Can’t imagine this is wanted.

Hi @Michael_Kolletzki ----- Thank you for the follow up and sharing the results of the work around here. @Rugby, always appreciate the input :wink:

I wanted to to touch base, as I had a moment to get some feedback from one of our developers on this report and the work around that was used here. According to our conversation this is common in old school ASIO drivers which has more to do with driver’s setting(s) and is not exclusively related to JRiver.