Roon unable to identify newly-loaded tracks

Roon Core Machine

Windows 10, Roon version 1.8 (build 814)

Networking Gear & Setup Details

Ethernet. Music discs directly USB-attached to PC running Roon

Description of Issue

Roon has largely completed the load of about 1000 new tracks. It is showing ‘Of 1077 tracks, 1077 added, 1053 identified’. However it has been stuck at this point for about 4 hours. It seems unable to finish what it’s try to do with the last 24 tracks but unwilling to give up and stop.

How can I find out which 24 tracks it’s stuck on?

Check for funny characters in names , accents, umlauts they often cause issues

Thanks. I’ll take a look.

Do you know if 1.8 became more sensitive to these than 1.7. From the look of the logs it got stuck on a folder it had previously loaded successfully which it was reloading for some reason… for reasons I can’t fathom it also decided to reload my entire collection of Blues recordings - about 10,000 tracks - none of which have changed recently. It ploughed through these in no time and then seems to have got stuck on some Bach - which may well be umlaut country… I’ll check.

Scratch that… I was looking at the wrong log file. Looking at the correct one it was a Bach recording it stopped on and it was one that it had previously loaded without a problem but it looks as though it was hitting a network problem. I think a little stopping and restarting of PC and network kit is in order…

There have been many reports of accents causing troubles not sure if its a 1.8 thing

I found a few accents and also some odd characters where somewhere along he line some piece of software had failed to translate a foreign accented letter into english but the half a dozen edits I have done haven’t cleared any of the issues. This may be the problem but I doubt it… and anyway this is a 222 disc set of Bach containing 5505 tracks. I know of no way to find all the potential issues except by eye-balling and that’s a fools errand.

Going back to the original issue the problem in the logs appears to present as a network problem. From the logs:

‘09/06 10:42:26 Warn: [identification] requeueing album that failed due to network (identifyalbum)
09/06 10:42:36 Info: [stats] 13329mb Virtual, 3000mb Physical, 2115mb Managed, 2764 Handles, 118 Threads
09/06 10:42:51 Info: [stats] 13281mb Virtual, 2940mb Physical, 2112mb Managed, 2747 Handles, 106 Threads
09/06 10:43:06 Info: [stats] 13313mb Virtual, 2940mb Physical, 2112mb Managed, 2811 Handles, 114 Threads
09/06 10:43:21 Info: [stats] 13265mb Virtual, 2940mb Physical, 2113mb Managed, 2778 Handles, 102 Threads
09/06 10:43:36 Info: [stats] 13317mb Virtual, 2939mb Physical, 2115mb Managed, 2866 Handles, 115 Threads
09/06 10:43:49 Trace: [identification] <7427119> Identifying album [Various Artists: Classical - Bach 333: J.S. Bach – The New Complete Edition] with 5505 tracks
09/06 10:43:49 Debug: [metadata http post req]:
09/06 10:43:49 Debug: [identification] <7427119> identifier request id: ffcd2979
09/06 10:43:49 Trace: [dbperf] flush 0 bytes, 0 ops in 415 ms (cumulative 1275824861 bytes, 1020320 ops in 461269 ms)
09/06 10:43:51 Debug: [identification] <7427119> status: NetworkFailure’

Now… I don’t think there is an obvious network problem as right before this the app loaded and identified a few thousand tracks which I had edited out Roon by altering the folder organization on the disc. I think that somewhere within the 222 disc 5505 track Bach set there is problemmatic data that it can’t handle. I would add that it has SUCCESSFULLY added all folders and all tracks but is stuck in the identification step.

As it can’t seem to tell me which discs/tracks are causing the problem the only things I can think of doing is to take the whole set out, clean up the database and then add them back in one disc at a time.

Does anyone have a better idea?

if you are already read in but not yet identified, maybe it can help to identify manually?

If it is found, maybe the characters set themselves so that the database has no more problems with it.

I believe I have identified the problem. I think there is some sort of limit in Roon to do with number of discs or number of tracks. For reasons that will be clear after my explanation, it’s not clear to me where this limit is. I realize this is a significant claim so I will explain my logic.

The Boxset in question is the Bach New Complete Edition which is I think a joint DG/Decca release. It is also known as Bach 333. It contains 222 discs and just over 5500 tracks. Most of it was loaded with only some tracks causing me a problem, I just couldn’t tell which tracks were failing, just that there was a stubborn number that it could add but not identify so the little wheel never stopped spinning. I moved the whole boxset from a watched to a non-watched folder then cleaned up my Roon library. I then began re-adding the discs (each disc in a folder by itself named disc 1, disc 2 etc) a few at a time. I successfully added 190 folders. On the 191st folder it hung. On the ‘Adding music to library’ dialogue the tracks on this disc were added but the tracks identified stayed at 0 for about 15 mins. I moved disc 191 back out of the watched folder and cleaned up the library again. I then started adding the tracks within disc 191 one at a time. I was able to add the first track and it was identified successfully and then not a single track more from disc 191 or from any of discs 192-222 could be identified: the add part happened fine but identified stayed at 0.

For a while I assumed there was something wrong with my data and I experimented with renaming tracks to ensure there were no special characters, shortened extra long names etc. No joy.

I then tried one more thing: I moved discs 180-189 out of the watched folder, cleaned the library and then tried again adding discs 191-199. It added and identified them all without issue. I then tried to load disc 189 which it had previously processed successfully and it hung. To me this means I’m hitting a limit and the only way of adding more tracks is to delete some of the ones I’ve previously added.

If anyone else has a better explanation I’d love to hear it but to my mind this means there is some sort of volume limit and with this boxset I’ve hit it. Now, one last complication… I wanted to say that the limit is around a single album but actually, for its own reasons Roon has created TWO albums from the 192 loaded discs. One it has called ‘Bach: The New Complete Edition’ the other ‘Bach 333: J.S. Bach - The New Complete Edition’. I can see no rhyme or reason to the way it has allocated discs to albums - there are 89 discs in one album and 102 in the other. This distinction is not as a result of my tagging as my album and artist tags are scrupulously uniform across the whole boxset, so it must come from its own metadata database (Roon knows best!). But this makes it hard (for me at least) to see where the limit I’m hitting could possibly be. It’s not the number of discs: I have a Beethoven Boxset with 118 discs: It may be a coincidence but all the discs from 180-199 are being added to the same album. It has 2,558 tracks in it. HOWEVER, although I can only add tracks to this album by deleting tacks from it to create room, the other album already has more tracks (and more discs) in it at 2,724.

In case I haven’t made it completely clear in my loose usage of the word ‘add’ the app is quite happy to add the extra tracks to its database, it is the identification step that it can’t complete. The last disc which it failed to identify - disc 189, the little wheel is still spinning as I type - is ‘added’ just fine: I can find it in one of the two albums and all the tracks on the disc are playable.

I’ve run out of things to try. If anyone has any suggestions please make them. Mostly, I would appreciate someone from Roon commenting on this.

1 Like

interesting observation certainly now a Roon employee should assess this further.

Update… sorry for dragging this on but I’ve become obsessed…

I renamed the two album folders (one with 89 albums one with 102 albums) to have names that are different from either of the two Roon has assigned. I then loaded the remaining 31 albums. They all loaded without issue into a third album with what appears to be Roon’s (if not my) preferred name for this boxset. So it definitely seems to be case of Roon ‘filling up’ an album to capacity and not being able to go on until you clear a path for it.

I’m now going to try merging all three big albums into one to see if I can do via merging what I can’t do via adding.

I was able to merge them into one folder. So you can do via merging what you can’t do via adding.

Took about 8 hours to get this sorted… shouldn’t be this hard. That ‘Network error’ message in the logs is really unhelpful.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.