Roon unable to load database at intervals

Roon Core Machine

NUC i5 with 128GB NVME and 1 TB SSD running ROCK

Networking Gear & Setup Details

Cisco un-managed switch, RV340 router, Netgear Orbi Wifi access points. Roon core and endpoints connected using 1Gbps Lan connections.

Connected Audio Devices

  • Matrix Audio Element X
  • RPI 4 (RopieeXL)+ Gustard X16
  • RPI 4 (RopieeXL) + Topping D90
  • RPI 4 (RopieeXL) + DX7 Pro

Number of Tracks in Library

10,000+ tracks

Description of Issue

Roon keeps failing to load database. After reboot it works for some time but again fails after few hours or next day.

Backup is working fine unlike the other case i read on the forum, so I am guessing no DB corruption? I have tried taking a backup and restoring it, works for some time and then recurs again.

This started happening from 2-3 days back. I have a bunch of DSP and device settings that i do not want to lose and will be very difficult to replicate again.

Can you give some more detail about what happens? Is there an error message, or does Roon freeze, for example? More detail will help diagnosis. Thanks.

It says, Unable to load database and gives me an option to restore. At that point of time, I can restore and sometimes it may work I can go to the ROCK web console and reboot the NUC, that will also work for a few hours. And in either case it will work for a few hours and the same will happen next day.

that sounds a lot like my issue (random error msg ‘there was an issue loading your database’, which fixes itself if I reboot the NUC/ROCK, after which a rescan happens. Then a few days later (sometimes 1 or 2 days, sometimes a week), the same thing happens. I have sent logs etc. to Roon support, as well as a copy of my Roonserver folder on Feb 24th. Radio silence since then…

I think there is a bug in the latest server release that is corrupting the database somehow. This is major problem for me. The other option is to format the NUC and move to a proper linux distro. At least system metrics, dmesg output etc will be visible. If that still doesn’t work then I think this will be the end of the road for me with Roon … :frowning:

:crossed_fingers: hoping not to go there. Really do not have time to tinker around with this right now… :frowning:

Hi … any updates on this? This is a paid software, what is the support sla? A basic response is expected at the very least… Right now, even a reboot is not helping… I’ll have to reset and restore the db again.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.