Roon unable to log into Tidal

I am able to log into Tidal, but not through Roon. My core is on a sonictransport. I run a win10 PC for the controller. I did delete the Roon cache. No luck.

Thanks, Tom

Have you tried a core reboot, that cured this for me last occurrence.

Yes, thanks. I also reset Roon on the sonictranspoter and powered down and up.

@Thomas_Baffa ----- Thank you for the report and sharing this observation you have made with us. The feedback is appreciated and sorry to hear of the troubles.

Moving forward, you can also try clearing your TIDAL cache:

  1. Quit Roon (or RoonServer)
  2. Find and open your Roon or RoonServer folder
  3. Locate and delete only the cache folder (Roon/Cache)
  4. Restart Roon

Let me know how it goes!


It appears you posted to my reply to someone trying to help.

In my original post I stated that I had already done what you posted. I use 3 win10 PCs and an Android as controllers for my Roon core on my sonictransporter. Tidal was available to them all but Roon could not log in. But the problem cured itself later that evening, they all came around. Glorious Mystery.



Hi @Thomas_Baffa ---- Thank you for pointing that out to me and my apologies for not catching that the first time around.

I see that the behavior seems to have corrected itself based on your most recent post but I wanted to check in before closing the thread out, to see how things have been holding up.

Looking forward to hearing your observations!

I have the same issue with Tidal, getting Network error: Please check your connection message trying to relog into my Tidal account on Roon. Tidal in Chrome works fine at the same time. Did reboot my core, cleared cache, any other suggestions?

Hi @Stepan_Ozernoy ---- Thank you for chiming in and sharing your feedback with me, very appreciated!

Moving forward, I am going to be enabling diagnostics on your account so our techs can have a closer look into this behavior for you. What this action will do is the next time Roon is active on your core machine a diagnostics report containing a set of your Roon logs will be automatically uploaded directly to our servers. I will confirm when the report has come in so you know we have it.


1 Like

Everything is working. I did reboot the sonictransporter, that runs Roon core, and powered off and several times. That must have worked.

Thanks, Tom

1 Like


Thanks a lot for keeping attention to my issue. I’ve tried to log in to Tidal half an hour ago - no luck again,same network error. Th thing is I’m leaving today and come back on April 30th so I’ll try to check if problem is still there only in a week - I’ll give you an update.

Hi @Stepan_Ozernoy ----- I just checked our servers and it looks like the diagnostics report has not made it to us. I have re-enabled this feature in an attempt to refresh the transfer but I want to make sure I get a set of your Roon logs over to our tech asap.

In light of the above may I kindly ask you to please use the instructions found here to gather and send a set of your Roon logs from the device hosting your Roon core. You can provide a download link to access the logs in a PM addressed to me.


1 Like

Ok, thanks, will do, but on April 30th when I come back to home :slight_smile: Please do not close this topic before that.

P.S. I’ve realized I can make a short stop at home in ~30min to check Roon + Tidal again - maybe my diagnostics report will show this time. If it doesn’t work - I’ll send you logs on the next week.

1 Like

Sounds like a plan @Stepan_Ozernoy, I appreciate you touching base with me. The topic will remain open and I will be keeping a close eye on our servers to see if the report makes it to us.

If it does arrive to us, I will be certain to provide you with an update ASAP.


1 Like

Well nope, same error, Tidal in browser works fine. I’ve relogged into Roon - same error, please check if you see anything in logs.

Hi @Stepan_Ozernoy ---- Thank you for sharing the above observation with me. Appreciated!

I just took a look at our servers again and it looks like the logs have not been received yet :face_with_head_bandage: I will re-fresh the transfer request again but at your earliest convenience would you kindly please send us over a set of your Roon logs using the instructions mentioned in my post above.

Additionally, can you please verify for me if you have any active firewalls or antivirus applications running anywhere in your setup. If you do indeed have active firewalls or antivirus applications running , may I kindly ask you to please temporarily disable these functions and confirm what the experience is like with TIDAL + Roon.


Well, sorry for a late reply, I finally sorted out my Tidal issue (well mostly, atm Roon doesn’t load albums covers while browsing Tidal, showing these only when added to my library, but that’s not that big deal for me). The reason of Tidal not working was that several IP addresses were blocked by my internet provider due to some stupid new directives of Russian government… so the cure was to set up a VPN service for Roon and run Roon traffic through it.

So, the issue was on my side, not on Roon servers one, but still thank you for help and keeping attention to it!

P.S. Tidal album covers also sorted out :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.