Roon Update 880 (Dec16-21) makes Roon unusable for me

Hey @Allan_Hall,

Thanks for letting us know. What steps have you tried already?

Yes, I have all of those.

Which one will work? Or work best?

And, is that really the solution or is Roon releasing a bug-fix (soon)?

And, finally, does this mean that my purpose-bought Samsung Galaxy Tab S2 (dedicated to use only as a Roon Remote) will no longer work for this purpose? Or wil; work only sometimes or with glitches? (NOTE: It worked flawlessly before this “update”).

Thank you.

Best regards,

Ok, Rebeka.
Latest update: I went ahead and put the Roon Remote app on my iPhone (which, by the way, I do not want to use as a long term solution for a Roon Remote - way too small - IMO). But, clearly would be fine as a temporary measure if it was the solution to getting my Roon platform up and running.

Unfortunately, using the iPhone as a Roon Remote did nothing towards allowing my Mac Mini Roon Core to update and hence make my streaming platform live again. For the record, the update process on the Mac went precisely the same way as described in my initial post above. That is:
“Over and over again, The update (shown in Settings → About) on the Core shows “downloading” progress bar until about 3/4 of the way through the bar, then before reachin g the end of the bar, it reverts to “installing” and then - in a few seconds - “There was an error checking for an update” message appears.”

I’m happy to temporarily use some other device to get back up and running … if it has a reasonable chance of success. Please advise which other device (if any) will work with a relatively high degree of certainty. I probably have somewhat ready access to most devices. Examples an Android phone, a couple of desktop PC’s running Windows 10, a Chromebook, a smaller, older Galaxy Tab A.

Please advise. Thank you.

Best regards,

Sorry to hear that, Allan. Thanks very much for weighing in though!

Hey Allan,

Also, I’m curious what are you running your Roon Core on? (Are you also, using a Mac Mini? If so, what year and OS?) What are you running for a Roon Remote?
Thanks, Allan!

Hey @William_Macdonald,

Thanks so much for using all this time and making efforts to see this through.

If the download keeps failing, no matter what you do, would you please:

  • uninstall Roon on your Mac Mini
  • restart the Mac Mini
  • download the latest build directly from our website
  • install Roon
1 Like

Am I going to loose all of my Favorites, Playlists Artist, etc., etc.?

Reinstalling the Roon software does not interfere with your database. Provided it is not corrupted, Roon will read it and you’ll pick up exactly where you left off.

For the first time ever, I’m having issues with a new build. Having to regularly stop and restart the core (Synology RS3617xs/RX1217/DSM 6.2.4-25556 Update 2). My network consists of enterprise grade router (Unifi UDM-Pro), enterprise switches (Dell X1052P, Dell PowerConnect 5548P), OM3 fibre backhaul, a boatload of Cat6 and enterprise wireless APs (BTW, Roon is wired/fibre only, wireless is only for phones/tablets). Another user described me as the Lionel Messi of home networking. Until 880, my Roon experience was flawless. Now it’s barely “Meh…”

This feels like a very “beta” build and I can’t believe it’s been released into the wild without more in-depth testing to iron out the somewhat obvious flakiness.

On the upside, at least my DB seems to be OK (said whilst firmly gripping a big, thick, slab-like ligneous object).

1 Like

Roon Core 1.8 build 880 on Win 10

On 2 systems in UK and Germany, fresh installs and the remote on iPad and Win PC can find no audio zones just as others have reported


Well that is one piece of (potentially - at least) welcome news. Although, this “corrupt data” issue referred to all over the Help forum, is a whole other issue - as I’m sure you recognize - which poses all kinds of underlying questions, that I won’t bother to get into here.

So, I reiterate my earlier question: Is Roon going to issue a bug-fix for this update that will solve this problem along with the litany of other issues, Please answer this question. Thank you, in advance.

(BTW, Rebeka, thank you for your help. I can see you are a very nice, friendly and courteous person as well as a diligent employee! Moreover, a well-trained (apparently, in the art of mediation) staff member). And thank you, once again for trying to help. However, I must say, Roon (as a Corporate entity) should be ashamed of itself for force-feeding an update that causes anywhere near this amount of time-wasting aggravation (among other things) to it’s customer base. This thing should never have come out of Beta!

There are a whole host of (what Roon should recognize) as VALUABLE customers who have (less than) no interest in becoming quasi ‘systems analysts’ (or beta testers) for “upgrades / updates” that are not bullet-proof upon release - especially for their hobby interests. If this was in the realm of my business interests I would simply have a IT tech deal with it and not care as much. Unfortunately, this is not an option here and will (undoubtedly) take up a bunch of my time in a completely non-enjoyable task - and that’s on the off-chance that things happen to go relatively smoothly with your advised uninstall and reinstall.

I feel like you actually empathize, Rebeka. I do not get the same feeling about Roon corporate!

1 Like

Fully in agreement

Well said!

and as you say

Is Roon going to issue a bug-fix for this update that will solve this problem along with the litany of other issues, Please answer this question. Thank you, in advance.


1 Like

Thank you, Graeme for responding to my humble total NOOB like post / cry for help! With that said, I’m truly sorry that this “build” has adversely impacted even the likes of a pro like you.

Thanks, again.

1 Like

Thanks, so much for your valued input, Edward!

Thanks for the support, Eric! I hope you are not too hampered here - but, alas I fear that is unlikely. Fingers crossed!

What’s the disk? Roon specifies an SSD. And it specifies macOS 10.14 (Mojave) or better. So your setup is pretty antique, though a Core i5 should be OK. I’d try upgrading your Core hardware to something that Roon officially supports. You might consider replacing that ancient version of macOS with a Linux distro like Ubuntu, which would bring you into spec if you already have an SSD.

Specs are at

Hi Bill,
It’s SSD. And, I checked with Roon on whether it was supported before I recently subscribed, and it was. (Possibly, that has changed, although that has not been indicated).
Upgrades are always nice … as I well know from years of upgrading in this hobby - not the computer side.
Thanks, for your thoughts.

Hi Bill, Roon 880 seems to be, in a nutshell, very flakey. I experienced some of the issues @William_Macdonald highlighted initially - the Android App seemed to be the last to hit the world, so after updating the core, Android controllers wouldn’t work as the 880 updated controller wasn’t available. A few hours later, this was resolved.

My Roon control Apps seem to constantly lose connectivity with the core - and there’s no way it’s network/hardware related. Roon runs off a bunch of RAID 0 SSDs (Core App and DB) on the RX1217. The Syno RS3617 has 32GB of RAM and a quad-core 3.3 GHz Xeon CPU. Network is 20GB/s to the main switch and all end points are cabled in Cat6 (Cat5e to a couple of the Sonos end-points - but they’re only 100BASE-T ethernet anyway). I’m on the fastest mainstream cable internet available in the UK and my speeds regularly exceed 600Mb/s.

I’ve also experienced issues with Qobuz since the update - had to logout and login several times to maintain access.

In my >12 months experience of Roon, this is the worst it’s ever been by a long way…


Hi, couple of Pennies/Cents Worth.

I complained about an issue yesterday about meta-data (after the up-date) but after looking at other post’s thought I would give the people who are are trying to sort this out a rest as poor Rebeka must be knackered with the lack of back up she is getting and a lot of customers are getting major problems when mine is a minor problem.

The more I look at the posts the more my mind goes back to the lack of business ethics with in ROON.

If I cock something up and cover it up (developing new techniques to manufacture turbine blades for commercial airliners) a plane may come down, people may die and I may spend time behind bars. This focus’s the ball’s up response.

ROON seem to reply on diversionary tactic’s.

ROON Guy’s, it’s better to admit a ball’s up, come clean with your hands up (even if you don’t know why yet), give an explanation and advise people how far you are along the timeline of getting things back to being usable or you end up looking like the worse politician out there.

Also, I don’t come to ROON to ask for way’s of fixing something I have done in my professional career because I tend to take responsibility for my own business actions so why doesn’t ROON.

It doesn’t work, it worked yesterday, analyse, repair, get it sorted internally. If you are a volunteer community then fine but you are a business taking money of people to provide a service. Why release if you think it may cause problems, will it help the business or not to release it???

Just a bit of handy advice, I will now leave you to get on with your extra work (caused by yourselves) as I luckily can use my system and hear some music (for now). Hope all others do before the Holidays.

All the best.


OK, I finally got Roon Update 880 back up and running. It was a pretty time consuming thing for me - oh, let’s be honest, I found it a big pain! (For many of you it’s probably a minor chore).

In the end, I uninstalled Roon Core and reinstalled.on the Mac Mini. And the Roon Remote App is now also working on my Samsung Galaxy Tab S2 same as before the update.

On the bright side, it appears that I didn’t lose all my albums, artists, playlists, etc. (So, that would point to the fact that my “data was not corrupt”, in my mind. (If so, (which Roon “tech Support” said in other posts) then, the question is: “Why did the Update not work for my Roon setup, without all this trouble?” Will that ever be answered by Roon?

Setting that aside, and the most important bright spot, is the SQ. (Incidentally, (and mentioned not to boast) I have acquired a very revealing 2-channel “audiophile / music lover” system over the years. At this point, I’m referring to everything BUT the computer side of my music system. That is all the other methods of playing tunes. My “computer-fi” at this point was intended to just ‘dip my feet in the water’. Not to get in too deep AND too EXPENSIVE! But, long story short, this update - upon initial listening - is an upgrade in sound quality. Sadly, it took so long to get any tunes that I’m tired of it right now. I’ll make one more post here as I listen a bit more in the days to follow.

One final note: in order to avoid this happening UPDATE crash scenario again, I’m updating my Core machine and will be running ROCK. I (hopefully, not wrongly - nor naively) feel like if Roon can’t seamlessly update to their own ROCK operating system, then …?! (And it will negate the type of comments posted above by @Bill_Janssen -as a possible excuse / cause of any future update grief.

Unfortunately, this was not an update that I wanted to undertake (financially) in the slightest right at this moment.

Finally, thank you to all the kind and helpful people on this forum for trying to bale out what I (still) consider inadequate Roon corporate responsibility for an actual company Support system. I say, this not withstanding Rebeka’s genuine efforts and attempts to help. Thank you, Rebeka - I think you are hamstrung by a cumbersome system in an admittedly challenging diversity of customer situations.

Onward and upward with Roon! (but, beware … you’ve got competition barking around. I still like Roon and really want to support it! Please make it bullet-proof for your customers that are simply music fans who want good tune and no hassle.

Cheers to all and Happy Holidays!