Roon update not happening

My Roon is telling me I need to update. However, Roon is not allowing me to do so. I’m using my dedicated (for home audio) 6th generation iPad with Roon installed. It’s going through a Pass Labs int250 integrated amp. Everything’s been working just fine for the 2 years I’ve owned it. I’ve downloaded updates before with no problems…until now. I’ve tried rebooting my iPad and Roon. I’ve unplugged and plugged cords back in.

You can probably tell I’m not very tech-y but I’ve never had this issue before. Roon tells me I’m running 2 different versions, 1.8 and 2.0. I don’t know how to uninstall and reinstall Roon on anything Apple. I’m much more familiar with Windows 10. I can’t get the Roon home page up that has “Settings” at the upper left so I can reconnect.

I’m lost. I don’t know where to go from here. All I need to do is get Roon working again on my iPad so I can stream my music. Can someone at least steer me in the right direction from here? Remember, I’m not very tech-y. But I’m pretty good looking…well, maybe not. Thank you so very sincerely for your help.

@Thomas_Williamson, I moved your post to the Support category so the Roon and the community can assist with your qusetions.

Can you please describe your setup using the questions below:

Describe The Issue
When you start a thread in the #support category, make sure to include:

  • What’s not working
  • How often the issue occurs

This could be “every time I start the app”, or “every time I click a certain button”, etc.
If you’re having a crash or an issue that happens sporadically, it’s helpful if you can let us know an approximate time for when it last happened.

Describe Your Setup

It’s important that you include all relevant setup information so our team can get a clear understanding of the issue.

Your post should include:

  • Details on your Core machine (OS, Hardware specs, Roon build)
  • Details on your Remote(s) (OS, Hardware specs, Roon build)
  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)
  • Audio devices in use
  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)
    Including these details in your first post helps us resolve your issues faster.

If you download the Roon app to your iPad from the App Store, can you go to Settings==>About and update your Core machine?

What is your Core machine? It isn’t the iPad.

I’m guessing your iPad is on Roon 2.0 and your Roon core (whatever it is) is on Roon 1.8. If that’s the case, you can go to the Apple App Store and install Roon Remote (Legacy) on your iPad and at least get it talking to your Roon core and playing music again.

Now, if your iPad is still on Roon 1.8 and your Roon core is on Roon 2.0, just go to the Apple App Store and install Roon Remote on your iPad. That will be the Roon 2.0 version. Do that, and you’re up to date and done.

As of yesterday, I can’t get the Roon “home page” so that I can stream my music. I tried to update Roon yesterday. I cannot get the Roon “home page” (the page with “Settings” in the upper left) to come up. It just keeps saying “Downloading” but nothing is happening. Maybe I’m not being patient enough? I’ve just let it sit for a few hours but it hasn’t made any difference. It’s acted like this since yesterday. Everything was working fine until I tried to do an update. My iPad is a 6th gen. The Roon is my only music source. Evidently I have both version 1.8 and 2.0 but I’m not able to download the update.

Thomas, what type of computer are you using for your Core? Can you please fill out the information requested in my earlier post?

Robert, I’m using a 6th gen iPod, but a friend just got me straightened out. He’s an IT guy. Everything’s working now. Thank you soooooo much for your help and advice. I truly appreciate it.

1 Like

Glad you are back working again, enjoy the music!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.