Roon USB Bridge & Tone Board (Khadas)

I finally got roon configured to use the USB Bridge with Armbian on a VIM2 SBC with an attached Tone Board. Works and sounds great. However, one annoying thing is, the Tone Board will NOT stay configured as an end-point. Everytime I turn the VIM2 and Tone Board on to use, I have to go into the roon setup and enable it under the ‘Audio’ category first. It won’t stay enabled, like all my other end-points.

Is this a function of the VIM2 SBC, or the way roon USB Bridge works?