Roon uses too much CPU and heats up Mac Mini

Core Machine (Operating system/System info/Roon build number)

  • core 2012 i5 Mac Mini Mojave 16G max x2 upsample with DSP convolution room correction
  • remote 2020 i7 Catalina 32G

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ethernet, Cisco

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Antelope Eclipse 384 USB

Description Of Issue

all seems OK on the Core, around 85% total CPU usage BUT

  • on the i7 running remote it starts out very low total CPU usage of a few %
  • creeps up to almost 50% and the Mini gets hot
  • I turn off Roon and it drops down to a few % and cools down
  • restart Roon and it jumps back up, gets hot
  • restart computer and it drops down to a few % runs cool

I find it very odd that the core CPU usage on an older, slower machine with less memory and doing upsampling with DSP is much lower than the remote

I can send screenshots of activity monitor, don’t see how to attach

1 Like

There’s quite few threads on this issue already; what you may try is

  1. quit Roon
  2. toggle WiFi networking on the mac
  3. restart Roon

Alternatively, reboot the Mac

thanks for the response, but I really don’t care how many other threads there are, and you stated exactly what I did

rebooting the Mac does drop the usage down… that’s not the point

the point is … Roon usage slowly creeps up therefore it should be fixed. Well written software does not slowly hog more and more resources until it heats up your computer

and I’m not using wifi on either machine

BTW I did see a thread going back over a year where others do have the same problem… Over a year with no solution… that’s ridiculous


But you didn’t read the thread I didn’t write that would say my Mac doesn’t use too much CPU or heat up! I bet there are loads of these.

Does your Mini have dual GPU? If so try turning off graphic cards switching.

i have no idea what you just said… is that a quadruple negative ??

I don’t think any Mac Minis have dual GPU ??

Well, triple at least.

Hello @bruce_bosler1, and thanks for your report! We have seen other reports like this recently and are currently working towards a solution. Could you please try disabling Wi-Fi on the mac and see if this brings usage back down to normal? That’s been working for other users experiencing this.

I’d also appreciate it if you could send me screenshots of activity monitor when this issue occurs so I can report the % utilization with the other users. Thanks!

I have a Mac Mini 2018, (16GB Mem, I7, 1 TB SSD) that has two heat problems related to high cpu utilization. One is Roon related the other is not.

The Roon related problem revolves around awakening the Roon dedicated Mac Mini from sleep. I allowed the Mac to go to sleep when it is not being used, meaning I’m not playing music on Roon. When it wakes up Roon consumes a large amount of CPU, (about 25%) and heats up to 180-200 F. At first I thought that Roon was catching up after being asleep, but it was going on for a sustained period so I decided to restart Roon and the problem went away. On the second instance, Roon went for about an hour until I heard the fan noise in a break from hearing some loud music. So, I restarted Roon and the problem went away. Lesson learned, don’t let the Mac Mini sleep. Everything is working fine now.

My second issue is with the kernel task running high CPU while playing music. This was iTunes at the time so this is not relevant to Roon. However, when I reported this to Apple, their response was that this was because of an eternal connection and not the Mac. The only external connection to Mac was a Netgear switch to which it was connected. I have other devices connected to this switch which includes a Windows laptiop, Apple TV, Roku and an A/V Receiver. I even connected a Linux computer and my son in law’s Macbook pro to the switch and none of these connections had problems. I solved it by connecting the MacMini to an Apple Airport Express in pass thru mode to the switch. My Mac Mini has failed where other computers and devices haven’t. With the work arounds, the Mac Mini works fine now and I’m is no mood to upset the apple cart.

I don’t have wifi enabled

It does seem to be related to going to sleep but doesn’t happen every time it does. First shot is high usage, shot below after a reboot

Thanks for the screenshots @bruce_bosler1, I’ll add this information to our tracker.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.