Roon using Synology NAS - Setup Error?

I recently adopted Roon, coming from JRiver, and I agree…it does sound better!

I’d like to access my files directly from my Synology D415+ on the network. My Roon control point is a CAPS 3 Zuma server running Win7 Home Premium which in turn routes the digital signal to a Wyred 4 Sound Recovery USB Reclocker then on to a McIntosh D100. I also use a remote which is an Android tablet.

I have not had any success connecting Roon to the NAS so I’ve loaded up the ZUMA with all my music files for now.

When I try to link Roon to the NAS I get a “Invalid Address” message. How do I determine what is a valid address for my Synology NAS and where can I find it?

Thanks for any assistance!

Hi @Michael_Kahut,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you share the path that you’re currently entering into Roon?

We have some additional information about configuring your NAS to work with Roon here.

Network is a CAT V wired network with a switch.

NAS is a Synology D415+ wired directly to that network.

Using 64-bit Roon version

I can’t remember what paths I’ve tried to use to enter into Roon. None of them worked so I didn’t keep them.

Network hardware:


Netgear 8 port Gigabit switch (GS108T)

I can see and access the NAS on the network with no issues.

I just need to know the naming convention and how to find the address Roon wants so I can connect to it.

Hi @Michael_Kahut,

The share should be in one of the following formats:

  • \\NASDRIVENAME\Music (for example)
  • smb://NASDRIVENAME/Music (for example)

You’ll want to make sure you’re using the correct username and password for the share too.

The best way to test the path outside of Roon is to open File Explorer or Finder and try entering the path there. If the path allows you to access the NAS there, that should work in Roon.