Roon v1.6 - Roon Software Server Constantly Reboots

I upgraded to v1.6 last week and earlier today my client lost connection while playing a track from my library.

The client then entered into a constant cycle of disconnecting and reconnecting - I did not see the client homepage.

I went onto the server website and saw that the server had stopped. I restarted and monitored the page while the client looked to reconnect. The server repeatedly restarted and eventually went into the stop state.

I re-installed the OS - this time I managed to browse my collection through the client and connected to my stereo to play a track. Unfortunately, the music played for c10s and then the client lost the connection.

I have also reset the IP address to a static address to see if something on my network might be causing the problem.

Can you point me in the direction of the server logs so that I can help triage this issue?

Thanks in advance

PS I am running ROCK on a dedicated i7 Intel NUC

Hi @Martin_Hopkins,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

I have also enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

  • what version of Roon you are running


  • What operating system you are running ( Windows 7; OSX 10.9; etc )

Intel NUC i7 with ROCK

  • Basic information about the device you’re using

8Gb RAM, 228Gb SSD

  • Describe where your music is stored – this includes hard drive description and interface type

Synology DS412+, shared folder, same network - (NUC is Both using Ethernet connection.

  • Let us know your collection size ( approximate number of tracks )

c960 albums, 12k tracks

If you use a fixed IP address it must be one that is not in the DHCP range pool, or one that has been reserved in the DHCP pool for that device.

Don’t forget to put in DNS entries for your router and at least one external DNS server like or if your ISP has nothing you should use.

Thanks for getting in touch. I changed from dynamic to static to rule out networking being the problem. Given the behaviour I’m seeing with the Roon server I reverted my configuratiojn to dynamic.

A client did run for a while recently and I saw it reporting a library scan. This morning the server had stopped which I restarted manually after the network change. I’ve also rebooted the NUC through the web app. Still seeing the same behaviour with the server.

Hopefully the logs will provide some insight into the issue.

Hi @Martin_Hopkins,

I spoke with the team about their analysis of the diagnostics report. They’re seeing some networking related errors in the report, so I was hoping to gather some additional information here.

Can you describe your networking setup? What networking hardware is in use and how are your devices connected?

Is this still occurring? Can you share a video of this happening?

A post was split to a new topic: RoonServer stops running on ROCK

The issue seems to have improved although not resolved. The ROCK O/S has now been up 23 hours since I rebooted, whereas the server is showing an uptime of 3hrs. My assumption therefore is that it rebooted.

I’m not sure what additional information you need on my network setup. As per a previous post, the Intel NUC running ROCK is on the same sub network as my Synology NAS. Rock now has a dynamic IP assigned by my Draytek Vigor 2860 router. My NAS has a fixed IP. Both have a gateway setting to the Vigor at which is also the DNS. Backup DNS is Google at Sub-net mask for both devices is Clients accessing the server run entirely on Apple devices. IPad, mobile are DHCP whereas macOS devices are fixed and dynamic.

I’ve worked all my life in IT both in developing software and also in networking. If you can share some information on what you’re seeing I might be able to triage my network, ie are you seeing duplicate IP addresses, issues with NAT etc?

Audio zones are a combination of chrome cast supporting devices (Naim Uniti, Onkyo, Google CA, Google homehub and displays) as well as Airplay. The first error occurred playing music through the Uniti.

Finally, I see that the server is now rescanning my music folders and is adding content. I’ve no idea why it is now starting to see additional content after being installed for many weeks.

Thanks for your help

Ok. Issue has re-occurred. I see a lot of log files on the ROCK server (RoonServer and RAATServer) with recent dates/times. Each seems to imply that the services are going through a start-up process. No sign that there are any issues due to networking in the log messages.

What’s the next we can do on this? I am trialling Quboz and so this issue is not only a pain as I cannot listen to any music, but I’m also not able to test out that service.


Hi - any progress on this?

Hi @Martin_Hopkins,

Please accept our apologies for the delay here. After your update previously I enabled diagnostics once more so we could take a look, but unfortunately, the diagnostics report has not reached our servers. I did a test and things seem okay on our end.

So we can move forward, I was hoping you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need the logs for the Core machine.

Hi - no problem. I’m sure you guys are busy. I rebooted the RoonServer which seems to have kicked-started things back into life. Am connected and listening to music. Result.

Logs files are here:


Thanks, @Martin_Hopkins. I’ll pass that along to the team and let you know when I receive their feedback.

Ok - this morning my client failed to connect. I looked into the logs and saw that the server is in a constant reboot cycle. I understand now that the website only updates status when the page is refreshed and the uptime is just Javascript and not a reflection of what is going on.

Seems you have a log cycle which increments and stores the last 20 logs. I browsed a lot of these as well as the RAATServer logs and can see nothing at the end of any log to indicate why the server restarts.

I deleted the Cache and also rebooted the NUC - no improvement.

I hear that you are passing details on to your team - when might I expect to hear back from them on this?

Hi Martin, I had a computer in the same state and it turned out to be a dying power supply droping power and causing a reboot. Have you check the voltages to see if they are stable?

Hi Daniel

Thanks for getting in touch and for the tip on power supply. I guess my post wasn’t clear when I used the term ‘server’. I was referring to the Roon Software Server not the hardware (thread title changed!). The Intel NUC I’m running isn’t rebooting.

It seems that I can get the Roon Software Server to stay up by closing all clients and then rebooting the Intel NUC. I then wait a while (c3hrs last time) and then connect my client. How long the system will stay us is anyone’s guess.

If anyone from Roon support can help in this I’d be really grateful. So far it’s been suggested that I have a networking issue. In my experience networking issues should not cause software to fail.

If I were a betting man, I’d be inclined to think that there is a software bug somewhere, made worse by a lack of debug logging at the point of failure. My hunch is based on having worked for many years in the software dev lifecycle. (I’ve also watched the Roon log file RoonServer_log.txt in real-time as it logs c254 lines and then reboots.)

Without assistance from Roon support it seems that I might have to live with a lame system, or wait until a software upgrade comes along with a fix. Having purchased a lifetime licence a few weeks’ ago it’s rather disappointing to have received little assistance from Roon in the last four days aside from the ‘tell us about your system’ (sorry Dylan), especially as I’m prepared to help the guys triage this problem so it doesn’t happen for others.

Here’s hoping my server is stable for a while…

Hi @Martin_Hopkins,

I met with our senior technical team to discuss this behavior that you’re experiencing. Upon investigation of the log files you sent over, our team has verified that the problems with the restarts of RoonServer are stemming from networking difficulties and suggested some next steps for troubleshooting.

Moving forward, I was hoping we could take a closer look at the current networking hardware in use.

Besides this router are you using any other networking hardware?

If you have one available, could you test to see if the same behavior occurs when a different router is in use?

Alternatively, can you share some screenshots of the networking settings available on this router so we can take a look and see if there is any settings changes that may improve things here?

I might optionally put money on a corrupt audio file in the system. I’ve personnally seen this.

Hi Dylan
I think I have gotten to the bottom of the issue, or at least I have made a change to a client setting that seems to settled things down.

I have a MacBook Pro connected to an Apple display. The display has wired ethernet and the MacBook Pro a wireless connection. I turned off the wireless and then rebooted the Roon Software Server - things seem stable.

If this is the root cause of my troubles then this is a bit of a nuisance, as I use my MacBook Pro a lot when I am out of my office. Having to turn wireless on and off to use Roon is not a great user experience, so I’d be grateful if you can confirm if this is indeed a use case that is causing problems.


Hi Martin, Does the Mac Pro get ethernet via the Apple Display as well as WiFi?

If so, then something might be getting confused when both are on. Are the two network connections on different sub-nets? Also, have you tried looking at Set Service Order to see which is the order of priority for the network connection and playing around with different priorities?