Roon v1.7 “windows-10-object-reference-not-set-to-an-instance-of-an-object”

I am using a Microsoft Surface Pro 3 (i5-4300U, 128GB SSD) as Roon control PC.

After updating Windows 10 to build 1903 Roon has stopped working.

When I launch Roon (v1.7) I get this error


I checked the log file and it mentions openGL, so I tried to find if there are updated graphics drivers available for my Surface Pro 3, with no success.

Below is an excerpt of my log file, in case it may help with solving my problems and that of the OP.


17:55:34 Error: Couldn't load WGL extension functions: System.ArgumentNullException: Il valore non può essere null.
Nome parametro: ptr
   in System.Runtime.InteropServices.Marshal.GetDelegateForFunctionPointer(IntPtr ptr, Type t)
   in Broo.Engine.OpenGL.Wgl.LoadWglExtensions()
12/06 17:55:34 Warn: System.NullReferenceException: Riferimento a un oggetto non impostato su un'istanza di oggetto.
   in Broo.Engine.OpenGL.Wgl.wglGetExtensionsStringARB(IntPtr hdc)
   in Broo.Engine.GlWindow.InitializeContexts()
   in Broo.Engine.GlWindow..ctor(OpenGlWindow glwin)
   in Broo.Engine.OpenGlWindow..ctor()
   in Broo.Engine.DeviceTarget..ctor(Window& window)
   in Broo.BrooLoader.Load(Boolean rendertrace, String brooxfile, String bindingsdllfile, String atlasname, Engine& engine, Window& window, LoadContext& loadcontext, String& err)
   in Sooloos.Application.Main(String[] argv)

Hi @Simone_Ragionieri, I’ve split out your report so that @support can focus on it independently to other reports.

1 Like

Hi @Simone_Ragionieri,

Can you please try updating your .NET framework and let me know if it helps?

Hi, I already have the .net 4.8 installed on my computer. It was part of win10 1903 update.

Hi @Simone_Ragionieri,

Thanks for confirming you have the latest .NET version. Can you please try running Intel’s Driver Assistant to see if you have the latest drivers for all GPU aspects?

Hi @noris, according to the Intel Driver & Support Assistant, my graphics drivers were updated.
I went on and downloaded the drivers and installed them anyway, and Roon started working fine again.

Case closed, thank you very much!

1 Like

Glad to hear that worked @Simone_Ragionieri!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.