Roon v1.8 & HQPlayer integration

I made a couple of changes to my playback software at the same time and now have some niggling playback issues.

Firstly, I upgraded to Roon v1.8. Secondly, I relocated HQP onto a dedicated Mac Mini M1 server, leaving Roon on its original Intel Mac Mini. To make it work, I updated Roon’s entry for HQP to point it at the M1 Mini’s IP address.

Now, I have two issues: (a) queued tracks in Roon get stuck, and I need to go into the Roon queue to manually kickstart playback of the next queued track; and (b) the track progress bar at the bottom of Roon is stuck at zero minutes during playback, although if I move it manually, it jumps playback to where I send it.

I have no idea whether these are Roon v1.8 bugs (I don’t see other folks complaining about them) or whether they have come about because I now use separate servers. The main components of integration (select a track and play it, control of the HQP volume from within Roon) work fine.

Any ideas please?

Do you have latest HQPlayer version installed? At least partially sounds like one of the bugs I was fixing not long ago.

Hi Jussi, yes, I am using desktop v4.10.1.

I cured one of the two problems by experimenting with HQPlayer and cured the issue where Roon’s time bar is stuck at zero. All it took was to select the “Time” radio button on HQP main panel. I think I had it on “Remain” previously.

However, the issues with queued tracks remains.

Thanks for any help/suggestions.

Actually, Jussi, that one simple change seems to have cured the queuing problem too. Crazy but true.

BTW, on a completely different issue, I cannot get HQP to output higher than 44.1kx256 to my NAA (an ultraRendu). I set it to 44.1kx512 (the limit of my DAC) but it ignores the setting and Roon reports DSD256. Is this a limitation of the Mac? I thought use of an NAA got around this?


Please check that you are playing native DSD to the DAC. So “SDM Pack” in HQPlayer preferences set to “None” instead of “DoP”.

Aha - of course! Thank you, Jussi!