Roon very busy under OS X


I’m seeing Roon consistently using 80-95% cpu on a quad core i7 MacBookPro Retina.
Granted, that’s not a lot on this box, but it does stick out as the top process consistently, even when not doing anything!

My library is on a synology NAS. It hasn’t been changed or modified.
The folders I have set up in Roon are watched folders, not organized ones.

There is no spinner in the top right of the UI, and the settings page would seem to indicate that ‘import’ has finished.
Indeed, my library stats have not changed since the spinner stopped.
The logs seem to indicate it is continually is finding “dirty” tracks, albums, or performers that need to be updated.
Roon seems to start at Z and work back through my library to A (and numerics) and then start over.
The "Trace: [library] " logs seem to indicate it finishes, and starts in again.

Is this all part of ongoing analysis? Should this finish at some point? (It’s been days now…)
Want logs?




1 Like

Several have reported similar behavior including myself. I hope the Roonies get it sorted out soon :wink:

here is what i posted elsewhere:

Im curious as to what is going on. We work pretty hard to be nice to your CPU, but 3 big things impact it:

  1. audio analysis. you can turn if off: settings -> setup -> audio analysis speed -> off), it may help a bit. “normal” should only use 5-10% of your CPU. “fast” uses a ton more.
  1. downsampling. Our downsampler, made by Meridian, is on the cutting edge of DSP technology, and arguably one of the best in the business. It requires a bit more horse power than other solutions out there, but the sound quality is awesome. You can see if it is being activated in the signal path popup… it only should be there if you are requiring a downsampling.
  1. importing. If you have a spinning circle in the upper right of your Roon window, next to bookmarks, you can click on it and see what’s going on. The import procedure is usually limited by the I/O capabilities of your hard drive, but if you have a fast SSD that can keep up, we will use more CPU. Once importing has slowed, you shouldn’t be using a lot of CPU.

Can you investigate these 3 items and see if any of this applies?

How big is your library? with 10k albums, my library can take like a week to do analysis.

Also, you are using 80-95% of 1 cpu or 80-95% of all 4 cpus?

Also, try build 21 – it has one fix related to start up CPU if you ever started radio in everything.

Thanks Danny!

As far as #2 and #3, I’m thinking those don’t apply. This happens when no music is playing, and I have no spinner in the upper right corner. My library appears imported. Granted, it’s an 80k track library. (so far.)

Other than turning audio analysis off, how can I tell if it is still running?
I did set the analysis speed to “fast”, in hopes that this might finish whatever it was doing, but to no avail.
Also, faster is better!

Under OSX, Activity Monitor just gives you a raw percentage, but going by the fact that this is a quad core i7, and the load average tends to about 3.x while this is happening, I’d guess it’s 80% of all my cores.
I do have audio analysis set to use 4 cores, and I use MenuMeters to visualize their activity (and their hyper threads!)
It does look like 4 of the “available” 8 cores are fairly busy.

I’ve also noticed that Roon is very polite, in the sense that it will immediately surrender CPU to anything else that needs some.
So while this keeps my MenuMeters looking pretty, and keeps Roon at the top of my Activity Monitor while nothing else is happening, it certainly doesn’t affect my laptop’s performance at all.
And, I’ve never had an issue with playback. Which is awesome! (well, since 1.0b16 which fixed my SMB NAS mount issue.)

So I guess what I’d like to know is how do we tell when analysis is finished?



“fast” means the analysis will use a lot of cpu :smile: I’ll get that cleaned up to be more clear.

if you have a big library, it can take a while… days and days…

in the next build, (22+) we have a progress thing next to the setting.