Roon VM sound popping

I just set up my Roon core in a VM, hoping to get a bit more out of my pc, and now everytime i play music through my stereo connected directly to the core I get a popping/snapping (It sounds almost like an old recordplayer) or sometimes completly distorted sound during the playback.
It doesn’t matter if Im listening to local library or to Qobuz or Tidal.
I had no issues when running on bare metal (same pc nothing about the hardware changed only added the VM).
I have tried increasing the VMs RAM to 8GB, I have messed around with the buffer size in Roon and I have tried downgrading from USB3 to USB2. None of it seems to work.
There are no issues with streaming to devices not connected to my core. I have got a Raspberry pi 3 running dietpi with Roon bridge and no issues.
Anyone got experience with this sort of thing and how to fix it?

My setup is as follows:
Roon 1.8 (build 898) in a VM running ubuntu server 20.04.3 with 6GB RAM and 4 cores(It seemed to be what it was using when it ran on bare metal). On a Lenovo ideacentre mini 5 running Proxmox VE 7.1 with a PS Audio Sprout100 connected via a USB3 port and passed through to the VM.

What’s the USB set-up of the VM? Are you direct hardware passing the DAC to the VM?

I suggest you passthrough the DAC / USB directly to the guest. This should avoid the hypervisor from interacting with the hardware. However, this requires hardware support and you don’t mention what exact CPU you’re using on the hypervisor to know if this is possible.

Im running a Intel Core i5-10400T. I tried what you suggested. Sadly it doesnt seem to work

Does proxmox support isoc USB? Many hypervisors don’t (like esxi)

Im not really sure. Im a bit new to Proxmox to be honest. What is isoc usb and how would I find out if Proxmox supports it?