Roon W10 Desktop Not Launching

Roon Core Machine

Ryzen 5900X
32gb RAM
RTX 3090 GPU
Windows 10 Pro

Networking Gear & Setup Details

Router: Ubiquiti Dream Machine SE
Connection: Ethernet
VPN: No

Connected Audio Devices

Desktop Application

Number of Tracks in Library

About 8000

Description of Issue

Just downloaded the Roon application after a recommendation from some friends. However, after downloading the application and running it, if the application is closed, minimized, or computer restarted, the app needs to be completely reinstalled every single time that I want to use it.

The Roon server application is running just fine on my server, but when trying to open the application on my desktop, it does not want to open unless freshly installed every single time. I’ve downloaded the latest GPU drivers, updated my .NET drivers, and still no luck. Disabled Windows firewall, created port forwarding for Roon Core, but the desktop app still won’t work. Roon Arc on my phone is working perfectly fine from anywhere.

I have six days left of the trial before it charges me, and while I really enjoy the application when it works, if I need to continue to reinstall it for it to work I would like to cancel my subscription.

Hi Aela,

You detailed your Core machine above. Can you detail your desktop where you are having the issue for support.

Confusing . Do you have a server and a Desktop remote or are you talking about a one purpose box

There are 2 versions of Roon, Roon Server and Roon “GUI” the of course Roon Remote for iOS etc.

Sounds like you have Server installed , do you have the GUI version on a second PC sounds like it

If a second PC how is it connected Wi Fi or Ethernet.

Good evening,

Sorry for the confusion. I have a server running Roon, which is working fantastic, but I cannot access via my W10 desktop PC, which is what has the listed specifications above.

Essentially, when I click on the desktop application on my Windows 10 PC, the app window opens but immediately stops responding. I have verified that the server portion is still functioning perfectly because I can access my Library on my iPhone.

Both the server and the desktop with the issue are connected via ethernet.

I hope this clarification helps.

Thank you,
-A

I had that once and ended up having to totally delete Roon from my Windows 10 computer and reinstall from:

Thank you,

I tried this a few times before making the post but that seemed to fix it! I don’t know what happened differently this time.

Thank you!
-A

1 Like

Update: the issue has returned. The desktop application will only work when freshly installed every time the computer is restarted.

Any ideas on a solution to fix it?

-A

Still searching for a solution for this problem. Any help would be appreciated.

-A

Hey @Aela_Johnson,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, are you still experiencing this issue? We’re not able to connect and enable diagnostics on the W10 desktop, if you could please use the directions found here and send over a set of logs to our File Uploader.

I’ll be on standby for your reply :+1: