Roon wants to speak 'Wasapi' to the local connected Bose Companion 50 Speakers

Roon Core Machine

Intel NUC 9 i5 (as adviced for ROCK, but now just installed in a windows config)

This thing is working just fine.

Networking Gear & Setup Details

Ubiquiti Unifi

Professional Wifi network installed.

Connected Audio Devices

Server: NUC > Roon Core

Endpoint riopee with tube headphone amp
A full sonosetup as roon endpoint.

Everything working just fine, exept for the issues above.

Number of Tracks in Library

88869 Tracks

Music on one external 6TB harddrive

Description of Issue

Hi, I have a dedicated Conference-Call-Laptop in another room. Now I want to play music using ROON using the connected Bose Companion 50 Speakers. So these are connected using USB.
As I see and can activate ‘Bose Companion 50’ in the audiosettings, I’m unable to play any music.
I noticed that I’m perfectly able to play music using the Qobuz app, and select the Bose Speakers using ‘Direct Sound’. I don’t think they understand Wasapi (which I also use on other devices to speak to dacs). How am I able to tell roon that it has to talk ‘directsound’ to these speakers. I see ‘Wasapi’ below the speakers in the audio overview, but am unable to change the protocol.
Anybody who knows the best way to use my bose companion 50 as an Roon endpoint?
I started with a raspberry pi with Ropiee, As I happily use that elsewhere, but that gave only a very distorted signal out of my speakers.
So first I try to get the thing going on this windows PC.

Thanks in advance!!


Hi @Thomas_Vandromme,

We’re sorry to hear you’re having trouble with your Bose desktop system.

Since there’s been a delay in getting to you I was wondering if you can give us an update on your status? Have you successfully gotten sound out of your Bose as of yet?

If not, please try system output or the High Definition Audio Device and change your settings in Windows system preferences to use the Bose as default.

Please let us know if this helps, we’ll be watching for your reply.

Hi Jamie,

Meanwhile, I solved this issue. It wasn’t a problem with Wasabi, but a lot of USB-speakers (like the ones from bose, beeing 2.1) want a 5.1 audio stream. So it was only untill I changed the setting to Channel Audio to ‘5.1’, and the setting ‘force mono or stereo output to 5.1’ that my system started working.
Working perfect ever since.

Kind regards,

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hey @Thomas_Vandromme

Thanks for sharing those details, I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones: