Roon will not connect to my NAS

Core Machine (Operating system/System info/Roon build number)

27" iMAc, late 2012, Quad core i7, 32 GB ram, 1TB fusion drive, Catalina 10.15.7, Roon build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Technicolour modem/ap (ISP is Shaw), DLink gigabit switch, QNAP TS-410 Nas connected ethernet (firmware 4.2.6 latest version), iMac is currently on WiFi for trial but plan on running Roon Core on a new Qnap or a dedicated iMac

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Linn Majik DS, ethernet

Description Of Issue

Roon will not connect to the NAS. iMac connects no problem and I think I have enabled smb support in the Nas (Microsoft Networking)

On my Linux-based setup, if I use Roon to connect to my remote storage, all Roon does is create a mount point on my core machine so it can access the files.

If you can manually connect to the NAS from the iMac, is simply connecting Roon to the already established link on your iMac (on your Desktop?) an option? Manually creating a mount at the operating system level and connecting to it should be equivalent to having Roon do the same exact thing through its interface.

Because it’s hard to debug someone else’s setup remotely because I’m flying blind other than your description above, there is also the possibility that if the NAS is mounted at the OS level while you’re simultaneously trying to remount the same NAS a second time from Roon that a collision is occurring where there might be something blocking a duplicate mount point. Possibly unmounting the OS connection and establishing a Roon-only mount might work. But that’s just a guess to consider and not a fact coming from a guru.

Hi @Len_Worley,

Can you share a screenshot of the path that you’re entering into Roon, as well as the error you’re receiving when you try to save it?


Does your NAS password contain any special characters?
Roon will not connect if it does.

Thanks Darryl

Tried mounting and then connecting. Network drive does not appear in the Roon choices. Tried unmounting network drive first no difference.

Here are a couple of screen shots. One with name’NAS’, one with IP address.

Thanks ogdens. Password is simple lower gas characters.

make that lower case. although there is often some lower gas around here as well

1 Like

Does this work as the path:


Otherwise all I can suggest is read this and check everything:

And also double check your network share setup via your OS.

The screenshots you provided have the caveat "only if required" under items like Workgroup. I wasn’t sure if you were using a local user’s credentials and whether leaving the workgroup field blank might have an affect. In other words, if the user isn’t a member of the workgroup, should that be included as part of the credentials? When connecting the NAS from the iMac, does that value need to be entered as part of that connection?

Just some random ideas to test…

All thoughts welcome at this point. Random or otherwise. I have tried with and without WORKGROUP, no difference

Hi @Len_Worley,

If you try to use Mac’s Connect to Server Feature (Method 2) to enter the IP of your NAS in Mac, are you able to connect to that IP?

What settings do you have set up in your QNAP, which version of SMB are you using? Can you share a few screenshots of your QNAP SMB settings?

Are you by any chance trying to connect with an invalid username? This is for the NAS itself, which typically has a username of “admin” set up.

Hi noris

Yes I can connect to the server using Connect to Server. Works with both name (NAS) and IP.

Not sure what version of smb my QNAP is using. Here are a few screen shots.

I have an account set up with username=Len Worley with admin privilege, user=admin is disabled.

Hi @Len_Worley,

Thanks for those screenshots! Can I please ask that you check to ensure that you still have this folder set up for sharing? You can use these instructions to do so:

Hi noris

Yes the Qmultimedia folder is set for sharing. Permissions are r/w for the Len Worley account. I also set up the Microsoft Networking Host Access Control to allow connections from my 10.0.1.* network.

Still no go.

Sorry to chime in but are you sure about the share name? The default multimedia share on my QNAP NAS is named Multimedia.

JFYI and completely btw.: Support for the TS-410 runs out by the end of this year (firmware 4.2.6 latest version for the TS-410 but current version for fully supported NAS devices is 4.5.1).

Hi @Len_Worley,

Can you please try to re-enabled admin and see if you are able to login with the admin account?

noris, something seems to be wrong the admin account it won’t accept any password I try. I could try resetting it but I’m a little concerned about doing that.

I know from previous cases, that special characters in the smb user password could cause issues. I am not sure, if this is still the case, but it might be worth a try:

If your password contains any special characters (äöüß()!"… ), could you check if the issue persists, if you temporarily change your password to one that only includes A-Z, a-z, and 0-9?

noris, I tried to re enable the account admin via the reset button on the back of then nas. The reset worked as the network settings were set back to dhcp but the account admin will still not accept any password I try (the default is supposed to be admin)