Roon will not connect to RoonServer on my QNAP NAS

Firmware Version:

Roon Core on SSD USB connected to NAS

Have had Roon successfully running since June 2018. This week I cannot get a connection to the Core.

  1. Turned off firewall…still no connection.
  2. Reinstalled Roon Server and saved RoonServer as shared drive.
  3. Checked that my id had Read/write to share - Yes
    Still looking for Roon Core
    It appears to see it and tries to initialize but then drops it and say “Choose your Roon Core”

Removed image

I have read the other support items but none seem to apply.

Any assistance would be appreciated.

I just saw that after I’ve posted. Also using the QNAP NAS to run Roon Core and can’t connect.

Seems to be a widespread issue.

Hey @Clarke_Carson — Thanks for reaching out!

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

  • What kind of remote are you using to try to connect to Roon?
  • Does this happen with multiple remotes or only one remote device?
  • Have you tried rebooting your Core machine, networking hardware, and remote device?
  • Are you able to connect to the NAS from your remote outside of Roon?


Roon Version: 1.5 (build 354)
OS: Win 10 64 Bit

  1. Desktop PC running Windows
  2. Mini iPad
  3. IPhone 6
    Storage: QNAP TS-251 NAS with 2x4Tb HD and a SanDisk SSD 500GB external storage (3.0 USB) with /RoonServer
    Music Collection: approximately 10,000 songs

Roonserver installed on SSD and QNAP Roon Server app indicates it is working and it is visible.
Installed Roon 64 bit version on PC and IOS versions on iPad and iPhone.
When is started on all Devices I receive the following message:
Choose Your Roon Core (which I have done) and and a grayed out message indicated it is initializing my connection to my NAS. (Screen capture follows)

I cannot find any menu or button that gives me an opportunity to change settings (nothing in upper left hand corner)

Again, any help would be appreciated. Thank You.

Hey @Clarke_Carson,

Just to verify, have your remotes ever been able to connect or is this a new behavior you’ve observed?

Can you describe your current networking setup for me? What networking hardware is in use (router, switches, etc.) and how are your devices connected?

Does rebooting your Core machine yield any changes?



Yes, I had Roon working from about mid June until late in August when my NAS stopped recognizing the externally attached SSD. I have purchased a new external SSD and formatted with the \RoonServer then installed Roon Core from the QNAP applications list. I attempted to run Roon off my PC & iPad/iPhone but got the screen I mentioned in my previous email.

I suspect that the roon software may not have the correct password to my NAS and hence just hangs showing the “initializing…” screen. But I cannot find a “settings” menu anywhere, although "help” tells me it should be in the upper left hand corner??

Network setup is a Luxul XBR 4400 router and a Luxul XAP 1510 access point. NAS is hardwired to router and all devices use access point.

I have since uninstalled both the roon core and roon software on the devices and rebooted my NAS…SUCCESS! I now have ROON running successfully!

Greatly appreciated your assistance.

Clarke Carson

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.