Roon will not display track data for Pendlebury "Don't Hold Back That Feeling"

I edited it in MP3 tag, copied it back, but get this same result:

Attempting to edit individual tracks in Roon gets nowhere.



After tag editing and making sure the filenames are correct etc.

  • Move the album folder / files out of the Roon watched folder to a temporary holding place.
  • Start Roon
  • Go into Settings --> Library - Clean up library
  • Is should show this tracks as missing.
  • Click on clean up deleted files.
  • Now move the file back to the Watched folder.
  • Roon should now import the files (as a new album).

Thanks Carl.

I had already tried that without success.

This time I carefully did the following:

  1. Deleted the album from Roon and cleaned the library.
  2. Shut down Roon and rebooted the PC
  3. Checked all the tracks were displaying correctly in another folder (a different HDD).
  4. Copied the file into the Roon HDD
    This is what showed via Windows Explorer in the Roon HDD

    So back to the Roon display to see this:

Roon just does not want to display that track information!!! Weird.

Agreed, I’ll tag @support to follow up with you.

If you identify the album, Roon should retrieve accurate track title information to replace the “Track 1”, “Track 2” stuff, which I assume is coming from your file tags.

Hi John,

Looking at your screen shots … I’ve just spotted that looking at your folder structure it looks like those 13 audio files are in the folder /Andrew Pendlebury/.

They should be in Andrew /Pendlebury/Don_t Hold Back That Feeling/.

Can you double check you don’t have two copies.
If only one copy move them into the Don_t Hold Back That Feeling/ folder.
If two copies them delete the rouge ones and double check the imbedded metadata is correct for the remaining ones.

Once the metadata tag are confirmed as correct edit the album in Roon at get it to re-identify.
If that does not work can you post a screen shot of the metadata for the file “1-01 Tied of Me

No, only one copy, but I see what you spotted and it does not look correct.

So I’ve adopted a different tack which has worked.

I imported the 13 tracks into Sooloos (it had not been there previously) and, surprise, surprise, it displayed the same as in Roon with no track data. So I edited in the correct data (on Sooloos it showed but greyed out in the background), saved and it then displayed properly via Sooloos.

Then exported and copied to the Roon HDD and … all tracks displayed. Obviously not Roon’s fault, just something odd about the track data.

Bottom line this has not explained what was going on, but maybe that really does not matter!

Hi John,

Good your have resolved this issue. However, there really should be no need to edit via Sooloos and then export the files. Editing can all be done directly to the files using say dBpoweramp or a tag editor of your choice. I’d recommend devoting some time to get familiar with this process.

Sound advice thanks Carl - your message has finally sunk in!!

I’m loathe to go through the hassles of learning new programs as most are rarely intuitive and the exercise ends up in frustration. I’m very familiar with Sooloos BUT editing there does not always translate into a corrected version for Roon so you are correct in advising not to use it any more.

But I’ve finally found an editing program which is not only free, but is intuitive and works like a charm. It is STAMP ID3 tag editor at

The beauty of it is to go direct to the file on the Roon HDD, select the track to edit, do the editing on it or other tracks using STAMP, then “upgrade” and hey-presto the corrected file displays in Roon :slight_smile:

Maybe there is finally hope for an old dog like me to get things right!!!

LATER: Not quite such a positive experience with STAMP, and BTW I did pay for registration so it was not a freebie in the end.
I spotted something that needed further editing in an album but each time it was loaded up, STAMP crashed. Most likely the problem would fix if I re-booted the PC but as I’m downloading a lot of stuff I will not do that now so will come back to it later. Anyway I reported the problem to them.