Roon will not open after mac reboot. Fatal Error: could not create lock file

Hey. i run Roon on a Mac mini. I just rebooted the mini. However, Roon now will not open. When i click on the app icon, I get a fatal error message “Could not create required lock file.” I have no idea how to fix this. help please as I have no music now. Thanks.

Let’s get @support to help.

Cheers, Greg

I just posted there, thanks.

Hi @John_Culver ----- My apologies for the troubles here. This sounds like a permissions issue to me, based on your description.

We have seen this type of error before and have documented ways of approaching this issue, which can be found here under “Installation Error On OSX”.

Let me know if the document/steps are confusing at all and I will be glad to lend a hand in clarifying the steps.


Thanks Eric.

I thought I had permissions set up properly as Roon has worked fine for over a month.

Anyway, I clicked on your link. terminal does not show under apps but I was able to find it. Clicked on icon and some text comes up. I have no idea how copy and paste into the terminal window. More help please.

My firewall is off.

I used the text editor to use the sudo command. inputted pw and was told there was no such file or directory

Help please

Tried Terminal instructions again. this time it did not say no such file, however room still will not open

Hi @John_Culver ---- Thank you for the follow-ups. Just an FYI, if you want to reach myself or the support staff directly you can use “@support” (no quotes), this will ensure that we don’t miss any of your posts.

Have you tried to re-boot the computer yet, since running the command lines in terminal?



i rebooted and still does not work-still get can’t create required lock file

Hi, I just had the same problem after reboot on MacMini. Roon has been running for months without problem. I will look forward to learning the fix.

@John_Culver ----- Thank you for confirming that for me. Have you tried reinstalling the application yet?


I thought about reinstalling. However, if I do, won’t I lose all my changes?


Hi Eric, I hope it’s ok to join this conversation. I have rebooted and then downloaded and reinstalled Roon and got the same Fatal Error message.

1 Like

Hi @stephen_condon ---- Thanks for chiming in here. Have you given this [procedure] ( a shot yet?



Is there a way to delete my current room download and redownload without losing all my changes?

Thanks Eric,
I haven’t tried that but, I have rebooted the computer many times before without problem. I did get a strange message after rebooting. ‘CoreTelephony Trace File Error. Error opening file/temp/ct.shutdown, err = operation not permitted.’ Not sure what that means.


I get the same core telephony message as well

Hi John,
I just checked Apple support and there is a discussion of the issue there. I wonder why this is cropping up all of a sudden.