Roon will not open after mac reboot. Fatal Error: could not create lock file

@support

Any word on solution?

@John_Culver ---- Looking into it right now, please stand by. Thanks!

-Eric

try to follow these instructions? http://www.macosxblog.com/how-to-fix-coretelephony-trace-file-error-on-mac/

also, double check you aren’t out of disk space

I’m like 95% sure the permissions on your /tmp directory are bad (the url above helps you fix that) – it explains the lock file error in Roon too.

@support

Thanks Danny

I tried 1-3 and still get th error message

Not sure how to create directory for solution 4???

@support

I also think I did not do 2 correctly. Where is /private? I searched in settings and did not find it.

John, Thanks for trying those. I tried #1 without success. I wasn’t sure what private was either.

In Finder, click Go, then Go To Folder. You will need to type /private with the slash.

Once you have the Private folder open, you can follow the instructions or press Apple + I to open the Info popup.

@support

Sorry, but can’t find Go under Finder, I clicked on everything

1 Like

@support

I am using screen saving and thus my desktop is a bit different

anyway, I am in sharing and permissions and it says read only, not sure how to change???

Thanks so much for the help

You’ll need to click the little lock to make changes, then you can click the various permissions (Read|Write) to change them.

@support

I was doing that, still won’t make change

@support

Unlocked, clicked on read and write, nothing, locked again, nothing, unlock, repeat, etc. Nothing.

@support

I am calling Apple, new mini, I get free support…

@support

Still on line…

was able to change to read and write (had to change all 3 user types), still not working…

Thanks John, For what it’s worth my MacMini is a 2012 I7 upgraded with ssd by OWC purchased at the end of June. I was unable to change permissions in /private folder, even after I unlocked it, it said I didn’t have permission to change read/write options. l only had read privileges.

@support

So, using the Mac OS blog instructions just about cratered my OS. MAC support says not to use them.

They are trying to find a fix now. i will post results.

@support

Eric or anyone from Roon. Apple is no help. They sent the issue to an engineer who will get back to me in a week.

In the meantime, I would sure love to have some music given how much I spent on the sw.

If I download a new Roon, I assume that will lose all the changes I have made (integrating tidal albums into my library, etc)?

Any more ideas? Seems awfully weird that a reboot would have this effect.

Thanks.

@support

BTW, Apple claims this is an issue with the iPhone sync to the iMac (something i didn’t think I had set yp). Not clear why that would prevent Roon from opening.

John, I deleted Roon and downloaded a new copy opened it and got the same error. I did not delete my Room library file.