Roon will not open after mac reboot. Fatal Error: could not create lock file

How do you delete one without deleting the other?Thanks

I deleted the application, the data file is stored in the library. It is found by holding the option key and then Library will appear on the Go menu.

I suppose if I moved the data file to another hard disk and then deleted Roon, rebooted we could see if the CoreTelephony error was being caused by a Roon bug, but I’d like to hear from support again before I tried it.

deleting the app wont help… the problem is your /tmp dir – Roon writes temporary files there, as do many other apps, and everything so far points to the fact that the permissions for that dir got messed up somehow…

in MacOS Terminal, can you paste this command:

ls -ld /tmp /private/tmp; id

and then paste the output? It’ll tell me if my theory is right and what commands to give you to fix them (since clearly the UI is confusing).

Thanks @danny, I have been able to clear the CoreTelephony Error but still getting the Fatal Error “Cannot Create Locked File”. Heres the paste:

ls -ld /tmp /private/tmp; idLast login: Tue Oct 18 06:04:04 on ttys000
miniTrois:~ stephencondon$ ls -ld /tmp /private/tmp; id
drwxrwxrwt@ 5 root wheel 170 Oct 18 05:29 /private/tmp
lrwxr-xr-x@ 1 root wheel 11 Jul 1 16:43 /tmp -> private/tmp
uid=501(stephencondon) gid=20(staff) groups=20(staff),12(everyone),61(localaccounts),79(_appserverusr),80(admin),81(_appserveradm),98(_lpadmin),33(_appstore),100(_lpoperator),204(_developer),395(com.apple.access_ftp),398(com.apple.access_screensharing),399(com.apple.access_ssh)
miniTrois:~ stephencondon$
[/quote]

I was not successful in changing privleges on the /private file even logged in as administrator.

@support

I am also not allowed to change to read and write. When i try to make the change, I get a pop up that says I do not have proper permission.

Help please.

BTW, how did you clear the core telephony error?

@support

Last login: Tue Oct 18 08:23:36 on ttys000
Johns-Mac-mini:~ johnculver$ ls -ld /tmp /private/tmp; id
drwxrwxrwt@ 3 root wheel 102 Oct 17 13:32 /private/tmp
lrwxr-xr-x@ 1 root wheel 11 Jul 8 22:26 /tmp -> private/tmp
uid=501(johnculver) gid=20(staff) groups=20(staff),12(everyone),61(localaccounts),79(_appserverusr),80(admin),81(_appserveradm),98(_lpadmin),33(_appstore),100(_lpoperator),204(_developer),395(com.apple.access_ftp),398(com.apple.access_screensharing-disabled),399(com.apple.access_ssh)
Johns-Mac-mini:~ johnculver$ L

And, here is my log.

@John_Culver
Hi John, I found the following solution at

https://origin-discussions-us.apple.com/thread/7695435?start=0&tstart=0

Here is a copy of the solution;

"I just encountered and fixed this issue on a family member’s Mac. Inspection of /tmp directory showed only contents a subdirectory “/tmp/notifcations”. It could not be removed and remained on rebooted system. After trying numerous suggestions including running disk utility and resetting permissions while in recovery mode, the following remedied.

Turn off System Integrity Protection and reboot to clear unwanted files in /tmp and restore needed file /tmp/ct.shutdown. Problem gone when rebooted. “/tmp/notifications” was removed. Error message gone. Reenabling System Integrity Protection did not bring back problem. Thinking El Capitan upgrade had failed to clean up after itself. Specific instructions as follows:

Reboot your Mac into Recovery Mode by restarting your computer and holding down Command+R until the Apple logo appears on your screen.
Click Utilities > Terminal.
In the Terminal window, type in ‘csrutil disable’ and press Enter.
Restart your Mac.
If error message gone, success!
Reboot your Mac into Recovery Mode by restarting your computer and holding down Command+R until the Apple logo appears on your screen.
Click Utilities > Terminal.
In the Terminal window, type in ‘csrutil enable’ and press Enter.
Restart Mac.

Credit to Jhmmy for putting me on the correct path to resolve."

This worked for me the first time, but as I said earlier still getting the Fatal Flaw on Roon.

@support

Thanks. I use screen share to access my mini and can’t get the mini to start in recovery mode. Not sure that error is the problem though.

Roon-any ideas about changing private to read & write (the likely problem). Or, some other fix to the "cannot create required lock file issue?

Thanks.

@support

Stephen-I have the mini in recovery mode now. Disk utilities is one of my choices, not utilities. And, i can’t find terminal (although I have been able to find it in regular mode). How do i pull up terminal in rm? Thanks.

@John_Culver ---- Please check your PMs, we’ve contacted you privately with an update.

Thanks!
-Eric

@support I posted a log for @Danny on this issue as well. Any idea of a fix for my situation.
Thanks

Roon will not run on a system that can’t write to the /tmp directory – we’re looking into what might have caused your permissions to get into this state, but we may have to wait for feedback from Apple before we can move forward here.

Thanks for your patience guys!

you guys appear to be in the same state, with /tmp (which is just a link to /private/tmp) is unwritable. the perms look right, so something else is wrong… either an update went bad, there was malware/virus issues, or something else broke /tmp.

your OS is not happy with /tmp broken, and core telephony is just one part of the brokenness. many many apps will be broken, including Roon.

Roon actually does not have permissions to cause this kind of damage… this issue was not caused by Roon, or any other “normal” software on your machine… only OS stuff (like an update) or malicious software (like a virus/malware) could have caused this.

Did any of the recovery mode advice work out for you @stephen_condon ?

We TeamViewered into @John_Culver’s box, but there is nothing that can be done other than to verify that it is indeed an issue with /tmp.

if you can get this command to succeed from terminal, your problem with /tmp is solved:

echo 1 > /tmp/foo

If that command succeeds and Roon is still not starting, I want to hear about that situation.

@danny I had no luck with the recover mode advice. I did clear the Core telephony error using the solution from apple.com.

All of my other software is performing as expected.

Roon is the only application that won’t start. I have not updated my OS to Sierra could it be a conflict with the newest Roon build and El Capitan 10.11.6?

The only thing I can think that may be different from other recent reboots is that I logged out before shutting down because I was going out of town for the weekend.

Thanks again for your help.

@danny Just tried echo 1 > /tmp/foo and got the following:

Last login: Tue Oct 18 12:09:28 on console
miniTrois:~ stephencondon$ echo 1 > /tmp/foo
-bash: /tmp/foo: Operation not permitted
miniTrois:~ stephencondon$

If you can’t write to /tmp (which the echo demonstrates), as much as you think everything is working, it is not actually working in reality.

For example, Roon writes a small lock file to /tmp on startup, which is why you are not starting up… if we skipped that lock file logic, most things would work fine, but updates wouldn’t work because they write out the downloaded update package to /tmp. So you would say “Roon works fine”, but then updates would be broken at a much later date. We are just catching the problem early.

As for Roon and compatibility, this is not an issue. Roon is not compatible with any operating system that lacks a temp directory. The OS you have installed is broken, as much as it may seem like it is not broken. Thousands of users used El Capitan, including myself and other team members. I have a Sierra and an El Capitan machine, and until recently, I had a Yosemite machine too. All ran Roon fine. However, they all had a working /tmp directory.

The fact that your echo is breaking with “Operation not permitted” is demonstration of a broken operating system, and not Roon at fault.

I told @mike and @eric – this is a pretty crap situation. I have no idea how OSX could get into this situation, but clearly others are running into it. If it was me, I would save my important files and reinstall the machine from scratch. Blah.

You have 2 choices here:

  1. visit an Apple Genius Bar and get them to fix this (maybe know they of a fix). Hopefully they will not tell you to reinstall from scratch.
  2. Reinstall from scratch.

There isn’t much more we can do from Roon’s side. We really do need the OS to be in a good state, which it is not in currently.

This problem has arisen for me in last 24 hours. I have read/write permission to the /tmp file, I am the only user of the Mac and have tried suggestions contained on this forum.

I am running OSX 10.11.6 on early 2015 MacBook Pro. Roon Core is on a Synolgy 916+

Danny’s comments on Jul 4 are unclear to me.

Roon Core seems to be running fine as still accessible via iPad etc.

Suggestions gratefully received.

Many thanks

Hi @pcrr,

I moved your post to this thread. Please read through it. If you think it should be moved back to the other thread, please let me know.

Cheers, Greg

Thanks Greg - having read these posts now, this is probably more relevant place but perhaps the title should be changed as I did see this title and didn’t think it was the problem I am facing. The “Fatal Error . . .” title seems to be more appropriate for a conversation on this issue.

It also seems that there is no solution to this right now, recognising that Danny’s comments indicate this is not actually a Roon issue at all.

I tried the ‘echo 1 > /tmp/foo’ command and received ‘operation not permitted’ response so I suppose even though the folder says I have rw permission, I don’t.

If this problem affects 10.11.6 users then there will be a lot of unhappy folk, Thank goodness for crieke’s NAS Roon Core!