Roon will not open on my Macbook Pro

Core Machine (Operating system/System info/Roon build number)
MacMini late 2012 (No issues).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
I do most of my listening through Roon Remote app installed on my Macbook Pro. It’s been working fine for weeks.

Now all of a sudden app will not open. Tried restarting the computer. Same result. Uninstalled Roon app and re installed it. Same result.

Would appreciate help resolving this issue. Thanks.

Try uninstalling with a cleaning up tools for Mac:
Then reinstall the Roon Mac client.

Hi @NAT3970,

Are things working okay on other remote devices?

Was there any change to your setup around this time? Any new apps or updates on the Mac?

Macmcl thanks for the suggestion. Re cleaning up tools I’ll do this if absolutely necessary but have had bad experiences with downloading this type of software in the past so would rather diagnose the issue through other methods first. Also I used Sensei app to do the uninstall. I use Sensei to monitor improve my mac performance but it also has an uninstall feature which believe it basically does what freemacsoft woud do.

Dylan, Other remote devices seem to be working fine. Issue seems to be limited to Macbook Pro not loading Roon app. I made no changes to the system during this time. No updates to Mac operating system either although several apps did go through routine updates. I’ve restarted the computer several times and have uninstalled (using Sensei) and re installed Roon 3 times.

Hello @NAT3970, and thanks for the information! Did your graphics card go through an update recently? Reinstalling the drivers might help. Also, when you’re in this state, is Roon opening and never getting past the logo? What do you see?

I’m almost certain graphics card did not go through any recent update.

Regarding what happens when I try to open the app, the word Roon appears for a split second and that’s it. It’s pretty much an “instant” failure to open the app.

The irony is that I’ve been on a 2 month trial with everything working perfectly and within hours of my going to paid subscription the app will not open. Is it possible that something changed on Roon end of things as a result of my switching from trial to regular subscription?

Needless to say this does not leave one with a warm and fuzzy feeling, particularly considering the timing.

Look forward to any guidance you can provide to resolve the issue.

Hello @NAT3970, and thanks for checking that. Could you try disabling your firewall/antivirus and seeing if Roon is able to open? If you can’t get it to open after that, please try:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

If there’s still an issue please let me know and we’ll enable diagnostics for your account!

nuwriy I followed all the instructions you outlined. I’m back to where I started. I’m unable to get Roon working on my Macbook Pro which happens to control the zone I use the most.

As previously mentioned everything was working fine right up to the change from trial to annual subscription. Its now been well over a week since I’ve been unable to use Roon in main listening location.

Please advise how to proceed i.e. enabling diagnostics per your last post. Thanks.

Hello @NAT3970, as we discussed previously, diagnostics would be the best next step. Please use the directions found here and send us over a set of logs using this link. Let me know when you’ve had a chance to do so and I’ll bring the report to our team!

Logs uploaded to link per your instructions. Look forward to your feedback. Thanks.

Hello @NAT3970, and thanks for uploading those files! I have submitted a report to our QA team and will return as soon as I’ve gathered their feedback. Thanks again for your patience.

Hello @NAT3970, I did a quick check myself at the logs you sent and it looks like they’re from your mac mini core. Could you please do the following from the Macbook Pro? Thanks!

Please use the directions found here and send us over a set of logs using this link.

Good afternoon nuwriy, Macbook Pro Logs have now been uploaded to the link you provided. Please ignore the first upload as I selected the wrong file on first try.

I’ll await your feedback on next steps. Thanks.

Hello @NAT3970, thanks again for your patience here. I got that information over to our team for further review!

Hello @NAT3970, our QA team took a look at the data you sent over and recommended the following:

  1. Stop Roon on the remote
  2. Check PM’s for this step
  3. Remove Roon folder on the remote
  4. Remove Roon from applications
  5. Install a fresh version of Roon app

nuwriy I was finally able to get my remote working again. I waited a few days before reporting back just to make sure that the fix worked and no issues present themselves. Roon now seems to be working as it was during the trial period.

I initially reported the issue in early July. While the issue has now been resolved as constructive feedback for Roon I would offer that the turn around times by QA team and ultimate diagnosis could/should have been faster.

I appreciate all your help and am clearly pleased that the issue has finally been resolved.

Hello @NAT3970, I’m glad things are working again! And yes, our apologies for the delay but we appreciate the feedback! Please let us know if you have any further issues.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.