Roon will not see Chromecast Audio

Core Machine (Operating system/System info/Roon build number)

Running an HP PC running Windows 10 as Core. Roon Version 1.6 (build 416).
Running Roon Bridge Version 1 (build 168) Allo USBridge attached to core with Cat 6.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router is SAGEMCOM FAST 2864

Wireless Access Point is an Arris VAP2500

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

HP (Core) attached by Cat6 to USBridge attached to a Nuprime DAC-9

When I first set up the CCA 2 days ago roon was able to see it and I played music to a portable speaker. Next day roon could not discover it. No luck at all since then.

I have:

  • reset CCA to factory settings and re set-up.
  • turned off and rebooted everything
  • tried Guest mode both off and on
    Note that the CCA will stream from Google music and appears to do everything it is supposed to do.
    I was able to ping the CCA from the Desktop successfully


Hi @Chris_Hornsby,

Can you elaborate on your current networking setup a bit?

  • How is the Windows Core connected to the network?
  • How is the CCA connected to the network?
  • Besides the router and and wireless access point, is there any other networking gear involved (like switches)?
  • Can you confirm that the Core machine and the CCA are both on the same subnet?

Hi Dylan

The Core is connected by wifi.
The CCA is wifi.
No other network gear.
The PC where the core is located has
The CCA has IP


Did you activate the Chromecast using the Google Home app??

Hi @Chris_Hornsby,

Is there any improvement if you connect the Core and CCA to the network via Ethernet?

Not sure how to do that but I will try to figure it out.

I will have to source a micro USB to RJ45 adaptor that includes a USB power supply. Is that correct?

Hi Dylan

I attached my PC with core to the router with Ethernet. Now it sees the CCA! Hopefully stays stable. I will keep my fingers crossed. Thanks!!

Hi Tom,

First time no but yes I did.

I solved this by attaching pc with Core to router with an Ethernet cable. Should have done this in the first place.

Thanks for chiming in though!

Regards, Chris

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.