Roon will not start on Windows 10 Core

I was about to start another thread with the same issue.
I have a lifetime license and my Roon core on Windows 10 that’s been running fine for a long time. It updated a few days ago to build 814. Ever since it gets stuck on the loading screen.
I tried updating Nvidia drivers as I’ve seen this somewhere recommended but didn’t help.
I tried installing the newly downloaded setup on top of the existing install but that also made no difference.
I don’t necessarily want to lose my library/playlists/history so is there any way to troubleshoot this?
I have logs attached if that helps.

You have missed networking details , there are so many variants , it’s better to show as much detail as possible.

It could be as bad as a corrupted db, easily fixed.

How old is your setup is your library new and still analysing maybe

Thanks for the reply.
As for networking, the machine uses on-board Intel Gigabit Ethernet with static IP, plugged into a Netgear Orbi Satellite. I also tried disabling the NIC and starting Roon with the same result.

The library hasn’t changed in quite a while. I also had it trying to start up for over 24h and it was still hanging on the loading screen.

How would I go about checking whether the db is corrupted and potentially fix that?

  1. See if Roon will start up.
  2. Scan the logs for potentially the words ‘corrupt’ or ‘corruption’?
  3. Send the logs to @support.

The only way to ‘fix’ a corrupt library is to Restore a previous Backup.

Thanks, I was afraid it may go that way.
Unfortunately, my only backup is 2 months old.

Been feeling pretty great about Roon besides some minor issues, and the problem with LSX’s but losing 2 months of playlist changes I’m not too happy about.

I always knew I should have had scheduled backups but still - more should be done inside Roon - and I’m speaking as a developer myself.

There may be a different problem for you than a corrupt database.

Wait to see what @support says before you do anything drastic.

I backup on multiple schedules and to multiple locations.


Hey @Alex_Marchard,

Thanks for getting in touch to let us know of the issue you ran into. We’re sorry!

Our technical team has taken a look at the logs you’ve shared (thanks for those) and the error they’ve seen point to TIDAL errors. Could you please:

  • Close Roon
  • Navigate to Roon’s Database Location
  • Locate the tidal_account file in Database/Registry/Core/tidal_account
  • Send us this file via Dropbox/Google Drive as a private message (click my name → message)
  • Delete it from your database location
  • Try to start Roon again

Thanks in advance :pray:

Thanks for your help. Deleting the file helped. I sent you a message with the Dropbox link.


Thanks! This is really great to hear.

We really do appreciate the file. It’ll help us a lot in investigating this :pray:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.