Roon will not turn on

Roon Core Machine

Nucleus+ (rev A) 94c691158E05

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hi,

I tried to turn my Nucleus on yesterday and it would not turn on, the white light does not turn on nor does it show up on the network as connected.

There were no changes to the set-up since last time it was used, I tried unpluging for 24hrs and repluging and it did not work.

What other steps can I take?

Thank you

I’d check your PSU first and see if it is still throwing out 19V ! Easy enough to do with a cheap DVM set to DC Volts.

yes I did, and unfortunately the PSU is working perfectly

sorry that autocorrected, i meant it i still not working at all. not turning on

Hey @Ariel_Merenstein,

Thank you for reaching out to us with your question. My apologies for the delayed response and for your wait. We’ve made some recent changes to the support team structure and some reports have experienced a longer response time than usual.

I’m sorry to hear that you were having issues with getting your Nucleus turned on. Since some time has passed I wanted to touch base to get your current status. If you’re still experiencing this problem and need assistance please let us know.

A few follow up questions for you:

  1. Does the light for the power button light up at all?
  2. Was there anything specific that occurred leading up to the Nucleus not working? Did you try a different power adapter or was there a power outage?
  3. If you connect the Nucleus to a monitor via HDMI and power it up does anything display?

As well as a first step to try:

Please try the following with the device:

  1. Unplug your Nucleus from the AC outlet and wait for about 15 minutes.
  2. Press and hold the power button for ~30 sec a few times. Do this with no power source connected to make sure the Nucleus is discharged completely.
  3. Connect the Nucleus to the AC outlet and try to turn it on.

Let me know if there is any change after this. We’ll be watching for your reply and get back in touch as quickly as we can. Thanks! :+1:

2 Likes

Hi,

I am glad you responded, thank you for answering.

I have tried all of thsoe things before as I read in the site that it had worked for other members. Unfortunately it did not work for me.

  1. The light button does not light at all.
  2. Nothing, same exact set up, power source, adapter, speakers. no change at all
  3. nada as well

any ideas here? what would be next steps?

Thank you,

Ari

Hey @Ariel_Merenstein,

Thanks for letting me know. Next, it would be good to take a look at the inside of the unit and see what the LEDs look like inside.

Can you unscrew and remove the bottom panel and, while the device is connected to power, take a picture of what you see? Are any LEDs lit up?

  1. Inside the box, can you see if a green LED on the NUC board and an amber LED on the front are lit?
  2. Is the Ethernet port lighting up when connected?

If possible, could you share an image of your device with the bottom panel removed?

Thanks for your continued patience here!

Hi Benjmain,

Good news! Both the green light on the circuit board and a red light near the front of the inside of the unit turn on. what does this mean?

Have a look at attached picture

Hope this means there is hope


Hey @Ariel_Merenstein,

Thanks for the update! You can try a CMOS battery reset procedure, that has sometimes brought boards back to life, long shot but worth a try if you are comfortable with a more technical procedure. Instructions and video below:

(Motherboard/CMOS shown at 5:55)

That may help, and if not, we can replace the motherboard on our end for a fee, since the unit is no longer under warranty. Let me know!

what would be the cost of that? If I wan to do it on my own, is there a off the shelf part I can buy to swap?

Hi benjamin, circlin on this in case you msised it the first itme.

Hey @Ariel_Merenstein,

I’m not able to comment on the cost at this moment but is something our accounts team will help with. Before looking to replace the motherboard, you do have the option to try a CMOS battery reset procedure.

Is this something you’ve already tried? Or, something you are not comfortable trying? Let me know and we can move forward with next steps!

CMOS Battery reset is the best bet as Ben says, the +5V standby is lit up on the board along with 12V rail. I had one with exactly the same symptoms last week, whipped the board out, disconnected the battery, re-seated the M.2 SSD and the Memory, left it overnight, reconnected and refitted the next day, all playing nicely and back from the dead. Very cheap, simple fix :wink: I wouldn’t start pricing up NUCs until you are 100% sure the one you have isn’t recoverable.

2 Likes