Roon will often skip through tracks

Core Machine (Operating system/System info/Roon build number)

Docker container (Linux) Server v1.7 (build 528)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sanskrit 6th USB DAC

Description Of Issue

Often when I open my Roon client and try to play something it just skips through all the tracks quickly never playing anything. If I exit and reopen Roon it will usually then play everything fine. It’s like 50/50 whether tracks will play when I open my Roon client (Windows PC).

Here is my server log showing the issue. This log was after a fresh reboot of the Roon server. I then opened Roon on the client computer 3 times. The first two times tracks played and the third it just skipped through tracks:!AjVnhushK5Vlg4AfDGm9_Fx8Cd72bA?e=rIbCe2

Edit to add - I have even tried reinstalling Roon on the client PC and it still behaves the same.

Hi @Kevin_ODonnell,

If you temporarily host the Roon Core on your Windows PC, does that behave the same as your Linux setup or does the Windows machine work as expected? You can switch Cores by using these intructions:

  • On the Windows PC go to Roon Settings -> General
  • Press Disconnect
  • On the “Choose your Core” screen press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time, but you are free to switch between Cores as often as you’d like.

Sorry so late in replying. I tried as you suggested and my Windows PC played fine every time I tried and when I switched back to the Linux server it played fine the first time I opened Roon, but the second time it just skipped tracks.

Any idea what this means? I’d rather not leave my Windows PC on all the time. My server is already on all the time. Any way to sort this out?

Hi @Kevin_ODonnell,

Thanks for checking the Windows PC and no worries regarding the delay.

Since you have you Core in a Docker container, it will be hard for us to say what exactly is going wrong here, we don’t perform any testing on Docker. You could try to reinstall the Roon app and clear out the RoonServer/RAATServer folders and that might help.

If the reinstall doesn’t help with the issues then I would try installing Roon on the native Linux OS instead of the Docker container and verify if that works as expected.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.