Roon window position and size not saving on Windows 11 (ref#NUL0UA)

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· Other

Describe the issue

Roon, for several months now, will not save the position or size of its window. I have tried a complete clean reinstall of Roon, tried setting the position file to not be read-only, but nothing works, it always just starts in a tiny window in the middle of my main monitor.

I am using Windows 11 Pro, with the latest version of Roon (build 1413).

Describe your network setup

I am using a standard Spectrum router into my PC, via ethernet.

Hey @Ellie_Gurrola,

Thanks for writing in! As a next step, close Roon. Navigate to the C:\Users(username)\AppData\Local\Roon\Database\Registry\Client folder. Find the saved_window_pos file and add a .old to the end of it. Reopen Roon and see if your issue persists.

Thanks!

Hello.

I gave this a try. Renamed the file, started the program up, positioned/sized it where I wanted it to be, closed it, then reopened it. It did the same thing it always does, where it starts on my main monitor as a very small window.

My observations of Roon for Windows’ behavior (single monitor setup):

  • early-access works as expected for a long time already and unchanged (size and position get restores)
  • production doesn’t work since some versions at all (neiter size or position get restored) and before only partially (only positions got restored).

I don’t know why the release of a working version (early-access) as production release should break that feature but it does.

1 Like

Thanks for the report @BlackJack and for the update @Ellie_Gurrola.

@Ellie_Gurrola if you’re able to review the same saved_window_pos file, you should see 4 specific numbered coordinates, that uses a decimal point as the decimal separator:
164,16,3028.8,1084.8

Do you see any negative numbers in your coordinates? If so, remove the negative sign, and let me know if your issue persists.

I see four coordinates, there are no decimal points however, and each coordinate is separated with the | character instead. Here’s the copy-paste from the file: -1927|0|1663|1038

Removing that negative actually did allow the program to load in its original size that I left it at, which it did not do before. However, the window started in the completely wrong position, it was nearly all the way off the screen on my main monitor with most of the it obscured, instead of completely off to the side of my right monitor.

Here is what position I closed it at, saves the file with a negative sign when I do:

And this is what happens when I reopen it with the negative sign removed:

Thanks for the report @Ellie_Gurrola - our team will take a closer look this week, and I should have more information to share afterward. :+1:

Hi @Ellie_Gurrola,

We’ve enabled advanced diagnostics for your Roon Server, could you please reboot your Roon Server twice, and let me know when completed?

Thanks!

I have rebooted it twice, it should be running now. Let me know if I need to do anything else!

Hi @Ellie_Gurrola,

Thank you :slightly_smiling_face: could you also send over a set of manual Roon logs? You can use the directions found here and send over a set of logs to our File Uploader.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.