Roon Windows (10) Client kills local LAN connection

Core Machine (Operating system/System info/Roon build number)

Roon Core is a QNAP hs-453dx NAS w/ Intel Celeron J4105 1.5Ghz 4GB running from ADATA SU800NS38 SSD ( QTS / 4.4.1146 Build 20191206 / 1.7 (build 511), QPKG 2019-06-09, Process ID 27943)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router: ISP provided Sagemcom F@st 5655v2 AC, running SG3G10000494, in PPP mode disabled WIFI, connecting the NAS with the Roon Core and the Switch/WIFI Bridge connecting the PC.

Switch/Bridge: Ignition Design Portal Wifi Router running in Bridge mode acting also as switch towards the PC

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Raspberry Pi 2 acting as Roon endpoint connecting a DAC/Amp.

Description Of Issue

Roon works flawlessly via iPad, iPhone app, but when trying to run the Windows Desktop client app on the PC the network connection is terminated right away, Roon does not find the core or any other Roon network devices (IP address and gateway are still shown in ipconfig, but no ping, no internet or any local network connection available). If I disconnect/reconnect the network plug on the PC, network is reconnected and all is functional. No other app causes issues.

I have tried to reinstall the Windows Roon Client from scratch, no change.

Please advise. Thank you.

Hi @Aron_Ecsedy,

Just so that you are aware, this QNAP does not meet our Minimum Requirements. I’m not saying that this issue is due to the minimum requirements just yet, but I wanted you to be aware of this aspect.

Just to confirm, you’re saying that when you open up the Roon Client app on your Windows PC, that your connection to the external internet is cut off? As in you can’t open up a web browser and navigate to any pages until the network cable is unplugged + re-plugged?

How are you starting the Windows Desktop app, are you using a mouse and keyboard or some kind of remote management software (Teamviewer/OpenVNC/Windows Remote Desktop)?

Do you have any active firewalls on this PC and have you added both Roon and RAATServer as exceptions there?

Hello Noris,

I understand your comment on the recommended hardware, but even like this I find the hardware excessively overpowered for the task. I have a CPU load while playing back HiRes FLAC MQA below 6%, with an init spike around 25%. RAM is a bigger issue but rarely exceeds 80% usage. Also, the HS-453DX was and still is marketed to be able to run Roon Server by QNAP.

As for your questions:

When I run the client application on my Windows PC all NETWORK access is cut off. No browsing, no file explorer or any other network connection to any other device. Ping does not reach the switch (Portal) or the Sagemcom router (both same IP range, Sagemcom is the DHCP server) either. At the same time all other network devices operate normally on the same network. Windows network settings show no connection outside. PC network access is restored after unplug/replug.

Roon Windows Desktop app is started normally using keyboard + mouse. I sit in front of the computer itself. No domain setup.

Windows Firewall is on, but both raatserver and roon.exe is allowed through. When I have now switched off the firewall completely, the Roon Client was able to identify the server, but after multiple tries it has failed to connect to it (it actually shows that it is able to communicate, tries connecting and fails), afterwards the same network cutoff issue persists, it is not possible to retry again (no network). I have tried to classify the network both public and private, same difference.

Note that this setup had worked only a couple of weeks ago. The only change I can recall since then is a major automatic Windows update.

Thanks
Áron

Hi @Aron_Ecsedy,

This might be the key factor here. Windows Updates sometimes reverts firewall settings, and even though you mention you have the Roon.exe and RAATServer.exe added as exceptions, I would try removing them and re-adding them again.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

Failing this, I would try to completely reinstall the Roon Windows Client by blowing away the Roon Client install, you can use these instructions to do so (on the Windows PC remote, not the Core):

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

Hi Noris,

Well, no. I have deleted the Windows Firewall exceptions and readded it at startup, no change. I have removed Roon (including directories), reinstalled, even restarted the NAS running the Core, it does exactly the same thing: finds the Roon Core first in “Ready” state for about 5-8 seconds, then starts “connecting” on its own, after a second or two changes to a red “connection failed” failed state, tries again, fail again, it does this maybe three times, then the start screen again with the look for Roon Cores button, but network is dead again.

I could not find any trace of a network log event during the time I was running Roon (in Windows Event Viewer). I can only see the disconnect/reconnect events.

Áron

Dunno if this is the same issue, but I have had all sorts of problems with Win 10 since a recent upgrade. It was an issue with SMBv1 if you are using Windows 10.

Basically Windows 10 Home and Windows 10 Professional still contain the SMBv1 client by default

So for Windows 10 - if the SMBv1 client or server is not used for 15 days in total (excluding any time during which the computer is off), they each automatically uninstall themselves. Automatic removal of SMBv1 after 15 days is a one-time operation. If an administrator re-installs SMBv1, no further attempts will be made to uninstall it (this is good news)

So you might check this:

Control Panel>programs and features>Turn Windows features on or off find SMB 1.0/CIFS File Sharing Support and check all the boxes - note it has three sub-items.

Then reboot your PC.

Hello @Olan_Henry ,

Thank you for the tip. I have checked. On my system these SMBv1 features had been off. As you have not been completely clear as to whether these should be on or off really, I did try to switch them back on. No change unfortunately, Roon still kills the network and does not run.

Cheers,
Áron

They should all be on.

On my NAS SMBv1 is allowed, however you cannot connect without a dedicated account/password (but this setup has not changed from before). Does really Roon use SMBv1? @noris?

Thanks
Áron

Hi @Aron_Ecsedy,

Yes, Roon uses SMBv1 for connecting to NAS shares, but I don’t think this is related to the issue you reported of losing internet access overall.

I wonder if logs show any additional information regarding this issue. Can I ask that you reproduce this behavior, note the exact local time + date in your country when it occurs again and then send me a copy of your Core + Remote logs by using these instructions?

There should be two archives, one for the QNAP and one for the Windows Client, and the best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either just let me know and I can provide alternate upload instructions.

@Aron_Ecsedy I have hidden the topic. Although anyone who has posted in the topic will still be able to see it. You might try sending the files to Noris attached in a Private Message referencing this thread and then deleting the forum post with the log links.

To send a private message, click on the Forum Avatar picture and select Message.

1 Like

Thanks, I have deleted the post and sent @noris the private message with the data.

1 Like

Hi @Aron_Ecsedy,

Thanks for sending those logs over, I can confirm I received them. I will get them over to QA for review and once I have a completed report I will be sure to reach out to you again, thanks in advance for your patience here!

1 Like

Hi @Aron_Ecsedy,

I took a look through the logs, but I am not seeing any signs of the issue starting there. Can you please confirm if the behavior occurs when the PC is hosting the Roon Core as well? To do this, you can go to Roon Settings -> General -> Disconnect -> (On "Choose your Core" screen) -> Use this PC.