Roon Windows Core loses connection to Cocktail Audio X45 intermittently [Resolved - faulty ethernet port on the PC]

Core Machine

Windows 10Pro 64 bit. Intel Celeron J4125 @2GHz. 8 GB RAM Mini PC

Network Details

All Gear is connected via CAT6 Ethernet
Using an 8 Port NetGear GB Switch (also tried an 8 Port TP-Link Switch but still had issue)

Audio Devices

Cocktail Audio X45 Roon Ready and Tested Music Streamer

Description of Issue

Intermittently get “Connection Lost” between Roon Core PC and Cocktail Audio device. It can happen several times within a few minutes and then go for up to an hour without losing connection. It does reconnect automatically and I can just select play and all is well again.
I have turned off all windows AntiVirus and Firewalls but still have the issue.
I know the PC specs are not exactly the recommendations but before I invest in more hardware I would like to make sure I am not missing something else to try.

Just realized that I have a Sonos ARC so I added it to Roon and the problem still exist. So that tells me the problem is at least not the audio source. Must be the PC or Roon.


Hello Dean

Welcome to our Roon Community! This is the perfect place to ask your questions when you run into issues with Roon. Unfortunately, you are trying to run your Roon Core on a machine that is well below our recommended system requirements and that can cause issues like the one that you’re seeing.

For more info on minimum system please see this help article

The best way to determine if this is your issue would be to migrate your core to another device and see if this corrects the problem. Do you have another machine that meets our minimum requirements that you could use for your Roon Core?

Hi Jamie,

Thanks for the response. I have pretty much determined that it is the faulty ethernet port on the PC. I have disabled it and connected via WIFI and its been running pretty much all day with no issues. I contacted the MFG and waiting on response.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hello @Dean_Giachino

Thank you for the update, I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones: