Roon with Apple TV

Core Machine

Mac mini (M1, 2020), Apple M1, 8GB RAM, macOS 11.4-20F71
Roon version 1.8 (build 795) stable

Network Details

Verizon router, Fios-G1100, WiFi 2.4GHz access point
Using same WiFi network to interconnect Mac mini and Apple TV (and iPhone)

Audio Devices

Mac mini “speakers”
Mac mini “system output”
Apple TV (A1625, 32GB, tvOS 14.6-18L569)

Library Size

5056 tracks

Description of Issue

I can’t play music to the Apple TV through the Roon Zone for the Apple TV.

I’m using the Roon app installed on the Core.

This is OK: In the Roon app, when I use the SystemOutput zone in Roon, I can play music to the Apple TV, when the Mac mini system output is set to the Apple TV (System Preferences → Sound → Output tab → select the Apple TV).

This is the PROBLEM: In the Roon app, in Settings → Audio, the Apple TV shows up as Roon Tested. It is enabled. (The Mac mini system output set to “Mac mini speakers”.) When I select the Apple TV zone in Roon and click the Play control in Roon, the status “dot” to the left of the Previous control lights green (sometimes amber) for a second or two then returns to gray. The Play control changes from displaying Pause to displaying Play.

Also OK: My iPhone also has no problem playing my Apple Music to the Apple TV.

Thank you.

Hello @David_Burkhardt and welcome to the Roon community :wave:

Thanks for sharing the issue you run into when trying to stream music to your AppleTV. If I understand correctly, even if you enable your Apple TV in Roon and select it as a Zone, you cannot stream music to it, correct?

Could you please send us a screenshot of your Zone Picker? And one of Settings → Audio?

Thanks in advance :pray:

Hi Rebeka,

Thank you for your response. Yes that’s correct. Screen shots attached.

Regards,
David

Follow-up: The prior screen shots were taken when my “New Apple TV” device was powered off. I just powered it on again, so here are two more screenshots. The same symptoms still occur as described originally when I have the New Apple TV zone selected and I click Play button.

Regards,
David

Hello @David_Burkhardt,

Thank you so much for being so thorough and sending us everything we’ve asked for. It will certainly help our technical team a lot in making suggestions for the next steps.

I’ve looped them in and you should hear back as soon as possible :nerd_face: