Roon with no internet

That is probably more likely the case.

Hi Simon, did Danny explain why Roon didn’t work with internet down?

Nothing as yet. I also need to do some more testing of my setup to rule out some things but not had time to do so yet.

I power down most nights . My startup involves powering up the modem and router. I do this before powering up the core PC.

If I cheat and switch on before the “internet light” shows on the router Roon fails to start, a restart always succeeds , so there must be some internet contact required despite the claimed “odd License check”

1 Like

Hey @danny I have this same issue, since 1.8.

All my remotes lock up if my internet goes down.

I’d be interested to know @CrystalGipsy’s network setup.

I have my modem (have had four modems two TP Link Archer VR1600v V2’s, Billion BiPac 8900X R3 and now onto a D-Link Python DSL-2888A) bridged into an ASUS RT-AC88U.

I’ve had ongoing NBN issues here in Australia since last November, they keep blaming my equipment but quite obviously after trying four modems, in IPoE, PPPoE and Bridged its quite obviously not my issue but the 600m of old copper cabling from the node to my house.

This issue with Roon has me wondering if there isn’t some problem with the ASUS DHCP implementation, I do run the Merlin version, which has been rock solid over the years.

I have full Unifi setup. ISP router is in modem mode so does nothing other than serve the internet. Unifi USG3 router feeds my main Unifi USW-60w switch. This feeds two further switches in two other rooms, 2 Unifi Access points, Nas and a few other IoT devices in the data cupboard. Off one of the mentioned switches lives my core running Rock and one zone, a steaming box another Unifi Access point. The other switch feeds my main living area with main hifi tvs etc. The WiFi is strong and I have great coverage across the building and beyond.

I run a number of subnets and wireless networks. All Roon RAAT and non Chromecast zones and.Roon core are on one. Plex runs on another with all my Chromecasts and Google TVs based things, rubbish IoT stuff on another and I have my main Lan.

Normally I just connect to the main labs WiFi for remotes and it all works swimmingly. Due to how Unifi works it allows you to have all Lans happily sending MDNS across for discovery and you can block certain ones to add what ever security you want. It’s not rocket science to get it too work. Roon finds the core connects easily sees all endpoints and is rock solid in this regard.

I decided to rule out the remotes being on a separate vlan and connected remotes to the Roon network. It connected once then
promptly locked up and got stuck in a similar loop. I got to this state a few times by hopping from one of my wireless networks to another, rebooting etc. This was with my phone a Google Pixel 4, Mac wouldn’t connect at all.

Yes I have a more complicated setup than some , but it works and no reason it shouldn’t when the internet goes down. I have to separate Roon off my main Lan as VPN for work was causing some fun with it.

Other apps I have for my Naim system worked fine which is on the Roon network from my main Lan or on the Roon network. Bubble UPnP could find my Chromecasts on a completely different subnet with no internet and would find all my UPnP devices when on the Roon network. Yet Roon remote doesn’t work in any of them without internet.

1 Like

Loss of internet again tonight.

This is what I get.

What I have noticed is that if remote is connected and hasnt been disconnected as happens when it’s in the background on Android then I can use it fine for local music. However close the app then it struggles to connect as seen above.

This was with remote on the same wireless vlan as all the Roon kit.

you are having trouble loading elements of the home screen that require an internet connection.

go to sidebar → albums… same, or does it load?

Hi Danny It just freezes the whole app. You can’t interact with it at all. Most of the time it won’t load and is stuck with a still Roon logo. Some times I get as far as what I showed above sometima further but then it will freeze if going to any conten. It’s not usable at all without internet and I am loosing it a lot at the moment.

1 Like

FWIW, if my net goes down I no longer have any access to Roon.

All remotes tell me that they cannot find the core.

This includes an iMac which is hard wired into the same synology router as my NUC runing ROCK and a synology NAS. My own music library is on a USB SSD attached to the NUC. The NAS is the master storage location and rsyncs to the USB SSD for roon library location.

When net is down I can still navigate to the NAS via the iMac, but Roon on the same iMac won’t connect to ROCK on the same router.

When this happens I play records and curse at ROCK.

1 Like

When my internet connection is down, i can still use Roon with my local library.

This is indeed worrying. What if you lost your internet connection. You wouldn’t be able to play local files!

This thread discusses that, but seen from a different perspective

It certainly is a problem if it stops you listening to local content when internet is unavailable.
If it really has to do this then cache the data locally until internet connectivity is available but under no circumstances should Roon throw its toys out the pram and prevent you listening locally (provided monthly license check has been done of course).

I’m open to correction but I think it would still work if there was no Internet it’s the active action of blocking that is the issue that stops play.

.sjb

This did occur to me, depends on exactly what the OP is blocking.

If my internet connection goes down, my local files play on.

Roon doesn’t work for me when internet is lost. The app will not connect to server. It will only work if it’s still connected to the server when it’s lost, but if it then is closed it won’t reconnect. I have posted this others have same issue. There is something with Roon since 1.8 and this regard. No other app has issues on my network with loss of internet exspt Plex which authenticates via their servers so Bork’s. My native system apps work fine, find devices and play music from Nas. Roon borks. This is because of all the Valence stuff. If you have no streaming services then it’s likely not affected but all those pages with valance content prevent the app from working.

My internet goes down almost once a week. My local files play with no problem. The only exception might be if the outage occurs just before Roon needs to reauthenticate your subscription, which is unlikely. Maybe @Geoff_Coupe might want to jump in to expand on this.

Do you have active subs to Tidal or Qobuz?

Not me - I’m just another user of Roon, not one of the developers… :smiley: